This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 151554

Summary: cdrecord -scanbus shows DVD burner as cdrom
Product: [Fedora] Fedora Reporter: Graham Cole <koujiacheng>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-04-27 06:04:39 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Graham Cole 2005-03-19 05:32:20 EST
Description of problem:

cdrecord -scanbus shows DVD burner as cdrom and I am unable to record CDs or DVDs

Version-Release number of selected component (if applicable):

How reproducible:
every time

Steps to Reproduce:
1. cdrecord -scanbus
2.  or attempt to record using dvdrecord
3.
  
Actual results:
scsidev: 'ATA'
devname: 'ATA'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version (schily - Red
Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c        1.83 04/05/20 Copyright
1997 J. Schilling').
scsibus0:
        0,0,0     0) 'PIONEER ' 'DVD-RW  DVR-108 ' '1.06' Removable CD-ROM
        0,1,0     1) 'JLMS    ' 'XJ-HD166S       ' 'DS18' Removable CD-ROM
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *


Expected results:
Expect it to show it as a dvd burner and be able to record.


Additional info:

Not sure if this is really a udev issue or what, but this seemed to work
properly before my last update.  udev was the only thing in there that I figured
could have possibly affected it.. but it's just a guess.
Comment 1 Harald Hoyer 2005-03-21 05:38:18 EST
udev does not handle your DVD or cdrom... it only creates device nodes.

do you have /dev/cdwriter* or /dev/dvdwriter* ??

If yes, try:

$ cdrecord dev=/dev/cdrwriter image.iso
Comment 2 Graham Cole 2005-03-21 10:11:27 EST
Both of those links exist.  Probably is not a udev issue then.

Very strange...  cdrecord seems to work most of the time now, but sometimes I
get the following error:

[diakka@charon xxx]$ dvdrecord -dao -dev=/dev/dvdwriter sling-err.iso
INFO: dvdrecord's functionality is now replaced by cdrecord
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in this version.
cdrecord: Cannot allocate memory. WARNING: Cannot do mlockall(2).
cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
cdrecord: Permission denied. WARNING: Cannot set priority using setpriority().
cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: '/dev/dvdwriter'
devname: '/dev/dvdwriter'
scsibus: -2 target: -2 lun: -2
Error trying to open /dev/dvdwriter exclusively ... retrying in 1 second.
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version (schily - Red
Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c        1.83 04/05/20 Copyright
1997 J. Schilling').
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   :
Vendor_info    : 'PIONEER '
Identifikation : 'DVD-RW  DVR-108 '
Revision       : '1.06'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
cdrecord: Found DVD media: using cdr_mdvd.
Using generic SCSI-3/mmc DVD-R(W) driver (mmc_mdvd).
Driver flags   : SWABAUDIO BURNFREE
Supported modes:
cdrecord: Drive does not support SAO recording.
cdrecord: Illegal write mode for this drive.
Comment 3 Harald Hoyer 2005-03-21 11:05:45 EST
I would suggest you use growisofs, which is superior to dvdrecord.

$ rpm -qf $(which growisofs)
dvd+rw-tools-5.21.4.10.8-6

$ growisofs -Z /dev/dvdwriter=sling-err.iso