This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 151605

Summary: german keyboardlayout no "at" "euro" "..." - powerbook g4 12"
Product: [Fedora] Fedora Reporter: shrek-m <shrek-m>
Component: kbdAssignee: Miloslav Trmač <mitr>
Status: CLOSED UPSTREAM QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: powerpc   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-04-30 11:22:50 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
pbg4 12" kbd us jpg
none
pbg4 12" kbd de jpg
none
PowerBook-specific de-latin1 none

Description shrek-m 2005-03-20 14:39:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.6) Gecko/20050308 Firefox/1.0.1 Fedora/1.0.1-5

Description of problem:
clean, fresh, german fc4t1 install
powerbook g4 12" - german

after the inst i had an english gnome-desktop.
i switched xorg.conf from us --> de-nodeadkeys
the most keys are correct now.
but unfortunately "at", "eur" and some other keys are not possible.
similar (not the same keys) happens in tty,
no "at", "eur", "german_umlauts", ...

Version-Release number of selected component (if applicable):
kbd-1.12-8

How reproducible:
Always

Steps to Reproduce:
1. clean fresh fct41 inst on a powerbook g4 12" - german
2. yum update kbd 
3. reboot
4. write an email at user@sld.tld
5. "@" should be [alt]+[l]

Actual Results:  no "@", wrong keyboard-layout.
'loadkeys us' and search the "@" = [shift]+[2]
with 'loadkeys mac-de-latin1-nodeadkeys' the keyboard is absolutely unusable.
oops,
'loadkeys de-latin1-nodeadkeys' and i get at least the "german_umlauts"

Expected Results:  all keys should print the expected signs in tty and in X.

Additional info:

this was configured while installation
----1----
$ cat /etc/sysconfig/keyboard
KEYBOARDTYPE="pc"
KEYTABLE="de-latin1-nodeadkeys"
----/1----


my change from us -> de-nodeadkeys in the xorg.conf
----2----
$ grep -2 nodeadkeys /etc/X11/xorg.conf
# or:
#       Option  "XkbLayout"     "de"
#       Option  "XkbVariant"    "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
--
#       Option      "XkbLayout" "us"
        Option  "XkbLayout"     "de"
        Option  "XkbVariant"    "nodeadkeys"
EndSection
----/2----
Comment 1 Miloslav Trmač 2005-03-20 15:03:18 EST
First, please strictly separate keyboard issues in X and in the console, they
are usually completely unrelated.
Let's solve the console part here, when the bug is reported about kbd.

First, please note than when you are using UTF-8, you have to use
(loadkeys -u MAP), not just (loadkeys MAPP) if you want non-ASCII characters
to work. (The fc4t1 initscripts should do that automatically,
so this affects only running loadkeys manually.)

AFAICS "@" in de-latin1{,-nodeadkeys} is (and probably always was) AltGr-Q.
mac-de-latin1 has "@" at Alt{,Gr}-Q and at Shift-AltGr-1.

I don't have any mac hardware here, so I don't know whether
the mac- or the PC map should work, or whether it depends on the type of
the keyboard; I'll ask some people who have the hardware.

So,
1) Does "AltGr-Q" work for getting "@"?
2) Why should "@" be at Alt-L? (Is it painted on the keyboard, is it
how other operating systems behave?)
Comment 2 shrek-m 2005-03-20 16:23:03 EST
Created attachment 112162 [details]
pbg4 12" kbd us jpg
Comment 3 shrek-m 2005-03-20 16:32:32 EST
mac_os_x - de
"@" = [alt]+[l]
"€""eur" = [alt]+[e]

the url of the attachment "powerbook g4 12" us kbd"
http://www.apple.com/powerbook/index12.html
--> take a closer look / view image
"@" = [shift]+[2]

asap i will take a photo of my pbg4 12" de kbd
unfortunately it has no "\" "|" "{" "}" "[" "]"
in think that i have to use a usb-keyboard in the future.
Comment 4 shrek-m 2005-03-21 04:33:54 EST
Created attachment 112168 [details]
pbg4 12" kbd de jpg
Comment 5 shrek-m 2005-04-03 09:37:55 EDT
usb-keyboard (de)
  X = all is ok
  tty = @{[]}\ are ok
  tty = €ßäöü ...  -->  something like "A¤"


+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-


powerbook-g4-keyboard (de)
AltGr = 1.[fn] + 2.[alt]

  "@" is ok (tty,X)
    ALtGr+Q = 1.[fn] + 2.[alt] + 3.[q]
  "|" is ok (tty,X)
    AltGr+< = [fn]+[alt]+[<]
  "€"  tty can not display "€", but X can
    AltGr+E = [fn]+[alt]+[e]


is not ok!
[fn]+[alt]+[7] should be "{" or "7"
  tty="beep" X="7"
[fn]+[alt]+[8] should be "[" or "8"
  tty="beep" X="8"
[fn]+[alt]+[9] should be "]" or "9"
  tty="beep" X="9"
[fn]+[alt]+[0] should be "}" or "/"
  tty="" X="/"
[fn]+[alt]+[ß] should be "\" or "="
  tty="~beep" X=""
Comment 6 Miloslav Trmač 2005-04-16 07:49:54 EDT
Thanks for the tests...
- The problems with German characters look like using or not using -u with
  loadkeys (-u should be used with UTF-8).
- Displaying "¤" instead of "€" is bug 127265
- I'll submit a patch upstream to add algr+l = @
- I don't know why altgr+number row doesn't work; it works fine on my PC.
  Is it possible that Fn+... works with the overlaid number pad?
  Maybe we'll figure it out.. please attach the output of (showkey -k) and
  (showkey -s) when pressing a) fn+alt+q, b) fn+alt+7.
Comment 7 shrek-m 2005-04-27 08:03:27 EDT
a) fn+alt+q

showkey -k
  keycode 100 press (fn+alt)
  keycode  16 press (fn+alt+q)

showkey -s
  0xe0 0x38
  0x10 0x90 0xe0 0xb8

b) fn+alt+7

showkey -k
  keycode 100 press (fn+alt)
  keycode  71 press (fn+alt+7)

showkey -s
  0xe0 0x38
  0x47 0xc7 0xe0 0xb8
Comment 8 Miloslav Trmač 2005-04-29 15:20:57 EDT
Created attachment 113867 [details]
PowerBook-specific de-latin1

Thanks, it is as I thought, fn+alt+7 is reported as "altgr+keypad 7".
Unfortunately altgr+keypad is already used in Linux (for specifying
characters by their Unicode code points), so this will require creating
a PowerBook-specific keymap upstream.

Please try the attached keymap using (loadkeys -u de-pb-latin1.map)
[note that it its not the -nodeadkeys keymap]. If it works correctly,
I'll send it upstream.
Comment 9 shrek-m 2005-04-30 08:23:25 EDT
wow :-)

@ is ok
  fn+alt+q = @
  fn+alt+l = @

thanks for the additional de-kbd behaviour because pb has no  {[]}\  and_no  ~
{[]} are ok
  fn+alt+7 = {
  fn+alt+8 = [
  fn+alt+9 = ]
  fn+alt+0 = }
  fn+alt+ß = "beep~"
   can you change this to
     fn+alt+ß = \
   and add
     fn+alt++ = ~


can you add the num-block behaviour?
should be fn+key, same as in us-pb-kbd except ","
 1 = fn+j
 2 = fn+k
 3 = fn+l
 4 = fn+u
 5 = fn+i
 6 = fn+o
 7 = fn+7
 8 = fn+8
 9 = fn+9
 0 = fn+m
 , = fn+.
 + = fn+-
 - = fn+ö
 * = fn+p
 / = fn+0
 = = fn+ß


i do not know if it make sense or is possible to add the additional function of
the F1-5,7,eject - keys.
 F1 = <brightness
  keycode 224
  0xe0 0x4c 0xe0 0xcc
 F2 = >brightness
  keycode 225
  0xe0 0x54 0xe0 0xd4
 F3 = mute/unmute
  keycode 113
  0xe0 0x20 0xe0 0xa0
 F4 = <volume
  keycode 114
  0xe0 0x2e 0xe0 0xae
 F5 = >volume
  keycode 115
  0xe0 0x30 0xe0 0xb0
 F7 = sync/unsync monitor
  no keycode.
 eject = eject
  keycode 161
  0x6c 0xec
Comment 10 shrek-m 2005-04-30 08:59:48 EDT
ßäÄöÖüÜ are ok now
altgr+e / fn+alt+e is displayed as "¤" should be "€"
Comment 11 shrek-m 2005-04-30 09:26:44 EDT
oops, deadkey
fn+alt++ = ~    is ok
Comment 12 Miloslav Trmač 2005-04-30 11:22:50 EDT
OK, glad to hear it mostly works.
- fn-alt-ß: is that another numeric keypad character?
- num-block behavior is, I think hardware controlled (there is no "fn" key
  in the dumps above)
- I don't think there are any predefined symbols for the special function keys.

So, I'll send the keymap (updated to have € instead of ¤) upstream, with
you on Cc:.  Hopefully it will get accepted soon, then we can ship it in Fedora.
Thanks for all the testing!
Comment 13 shrek-m 2005-05-06 16:07:37 EDT
1;
fn+alt+ß = \
is the missing backslash on the german powerbook-keyboard.
the regular german keyboard layout is  AltGr+ß = \



2;
i believe that this temporary num-lock, on notebooks mostly blue colored, could
be realized, here are the dumps.
first testings:
j = 36 , fn+j = 79 , numlock j = 79
k = 37 , fn+k = 80 , numlock k = 80

here the dumps:
1 = fn+j
  79
  0x4f 0xcf

2 = fn+k
  80
  0x50 0xd0

3 = fn+l
  81
  0x51 0xd1

4 = fn+u
  75
  0x4b 0xcb

5 = fn+i
  76
  0x4c 0xcc

6 = fn+o
  77
  0x4d 0xcd

7 = fn+7
  71
  0x47 0xc7

8 = fn+8
  72
  0x48 0xc8

9 = fn+9
  73
  0x49 0xc9

0 = fn+m
  82
  0x52 0xd2

, = fn+.
  83
  0x53 0xd3

+ = fn+-
  78
  0x4e 0xce

- = fn+ö
  74
  0x4a 0xca

* = fn+p
  55
  0x37 0xb7

/ = fn+0
  98
  0xe0 0x35 0xe0 0xb5

= = fn+ß
  117
  0x59 0xd9



3;
surely no symbols :-)
it would be great if there would be some time the appropriate functions.