Bug 1516210

Summary: OSP11 -> OSP12 upgrade: when UpgradeRemoveUnusedPackages is set to true the upgrade-non-controller.sh fails with expected string or buffer
Product: Red Hat OpenStack Reporter: Marius Cornea <mcornea>
Component: openstack-tripleo-commonAssignee: Marios Andreou <mandreou>
Status: CLOSED ERRATA QA Contact: Marius Cornea <mcornea>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 12.0 (Pike)CC: dbecker, mandreou, mbracho, mbultel, mburns, morazi, rhel-osp-director-maint, sathlang, slinaber
Target Milestone: rcKeywords: Triaged
Target Release: 12.0 (Pike)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-common-7.6.3-6.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-12-13 22:22:16 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Marius Cornea 2017-11-22 09:48:22 UTC
Description of problem:
OSP11 -> OSP12 upgrade: when UpgradeRemoveUnusedPackages is set to true the upgrade-non-controller.sh fails with expected string or buffer

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-7.0.3-10.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP11 with 1 controller + 1 compute
2. When upgrading set UpgradeRemoveUnusedPackages to true 
3. Run major-upgrade-composable-steps-docker.yaml
4. Run upgrade-non-controller.sh --upgrade compute-0

Actual results:

(undercloud) [stack@undercloud-0 ~]$ upgrade-non-controller.sh --upgrade compute-0
Wed Nov 22 04:36:00 EST 2017 upgrade-non-controller.sh Logging to upgrade-non-controller.sh-compute-0
Wed Nov 22 04:36:04 EST 2017 upgrade-non-controller.sh nova node compute-0 found with IP 192.168.24.16 
Wed Nov 22 04:36:04 EST 2017 upgrade-non-controller.sh Executing /root/tripleo_upgrade_node.sh on 192.168.24.16
 "nova_compute",
Wed Nov 22 09:36:04 UTC 2017 819f2177-7f47-4f12-95bf-2b0211bee23d tripleo-upgrade compute-0 /root/tripleo_upgrade_node.sh has completed - moving onto ansible playbooks
Wed Nov 22 04:36:04 EST 2017 upgrade-non-controller.sh Clearing any existing dir compute-0 and downloading config
expected string or buffer

Expected results:
The compute node gets upgraded without errors.

Additional info:

Comment 1 Marios Andreou 2017-11-22 16:32:58 UTC
this looks to be a regression in openstack overcloud config download:

(undercloud) [stack@undercloud-0 MARIOS]$   openstack overcloud config download --config-dir "$UPGRADE_NODE"             
expected string or buffer

The error is happening here https://github.com/openstack/tripleo-common/blob/9f5e38e7d398c60af4d165943417dbde70639d53/scripts/upgrade-non-controller.sh#L182 during the upgrade-non-controller run, but the error comes from config download itself

Comment 2 Marios Andreou 2017-11-28 12:54:33 UTC
*** Bug 1516308 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2017-12-13 22:22:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462