Bug 1516475

Summary: Install of Fedora 27 made system unbootable
Product: [Fedora] Fedora Reporter: Fred J. Tydeman <tydeman>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 27CC: anaconda-maint-list, jkonecny, jonathan, kellin, tydeman, vanmeeuwen+fedora, vpodzime, vponcova, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-11-23 09:16:45 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Fred J. Tydeman 2017-11-22 17:24:11 UTC
Description of problem:
Install of 64-bit Fedora 27 (LXDE live spin) to its own / and existing /boot/efi made existing Windows 10, Fedora 25, Fedora 26 (as well as new Fedora 27) unbootable.  During the install of Fedora 27, there was an error message about install of boot failed.  Now, when I power on the computer and end up at a boot menu, when I pick Fedora, I get a blank screen for a second or so and back at the boot menu.  When I pick Windows, I also get a blank screen for a second or so and back at boot menu.  I have restored the /boot/efi partition from a backup and the problem still exists.  I am now in the process of restoring the entire disk from a backup (takes 2 hours).

Version-Release number of selected component (if applicable):
Fedora 27 LXDE live spin.

How reproducible:
Have tried once so far.
Will try a second time (this time with BIOS in UEFI only)

Steps to Reproduce:
BIOS:  Both UEFI and CSM compatibility with CSM tried first.
Partitions:  GPT (not MBR); a mixture of OS and data partitions.
Disk:  Solid state disk via nvme (not sda)
System had existing 64-bit versions of Windows 10, Fedora 25, Fedora 26.
Boot Fedora 27 live on USB memory stick.  Do install to hard disk.  Pick / (format) and /boot/efi (existing).
Get error message about boot install failure.  Rest of install finished.

Actual results:
System is unbootable

Expected results:
Should be able to boot Windows 10, Fedora 25, Fedora 26, Fedora 27.

Additional info:

Comment 1 Fred J. Tydeman 2017-11-22 21:00:03 UTC
After restore, Win 10, Fedora 25 and 26 were bootable.
Changed BIOS to be just UEFI.
Booted Fedora 27 live from USB memory stick and installed to disk.  
This time, did not get error message about unable to write boot.
Power off, power on.
Can boot Win 10 and Fedora 27.
But, now both Fedora 25 and Fedora 26 start booting, but fail trying to mount
/boot/efi which kills the boot process.

Comment 2 Jiri Konecny 2017-11-23 07:48:16 UTC
Hello,

Could you please give us logs from installation as plain text files. You can find them in /tmp/*.log.

Thanks you.

Comment 3 Jiri Konecny 2017-11-23 09:16:45 UTC
I think you are trying to do the same as the bug 1488204. So I'm closing this bug as a duplicate.

*** This bug has been marked as a duplicate of bug 1488204 ***

Comment 4 Jiri Konecny 2017-11-23 09:17:36 UTC
Clearing the needinfo flag.