Bug 1518666

Summary: RHCS upgrade 2.4 - 3.0: Fails with "msg": "file (/var/log/ganesha) is absent, cannot continue"
Product: Red Hat Ceph Storage Reporter: Parikshith <pbyregow>
Component: Ceph-AnsibleAssignee: leseb <shan>
Status: CLOSED NOTABUG QA Contact: ceph-qe-bugs <ceph-qe-bugs>
Severity: low Docs Contact: Bara Ancincova <bancinco>
Priority: unspecified    
Version: 3.0CC: adeza, aschoen, ceph-eng-bugs, gmeno, hnallurv, nthomas, sankarshan, shan
Target Milestone: rc   
Target Release: 3.*   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Known Issue
Doc Text:
.Ansible fails to upgrade NFS Ganesha nodes Ansible fails to upgrade NFS Ganesha nodes because the `rolling-update.yml` playbook searches for the `/var/log/ganesha/` directory that does not exist. Consequently, the upgrading process terminates with the following error message: ---- "msg": "file (/var/log/ganesha) is absent, cannot continue" ---- To work around this problem, create `/var/log/ganesha/` manually.
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-01-10 16:38:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1494421    
Attachments:
Description Flags
upgrade log none

Description Parikshith 2017-11-29 12:43:18 UTC
Created attachment 1360291 [details]
upgrade log

Description of problem:
rolling upgrade fails while upgrading nfs client since ceph-ansible searches for /var/log/ganesha, but on the nfs client that particular file will be /var/log/ganesha.log 

Version-Release number of selected component (if applicable):
RHEL - 12.2.1-40

How reproducible:


Steps to Reproduce:
1. Configure 2.4 cluster with nfs(manually). 
2. Upgrade to 3.0.


Actual results:

TASK [ceph-nfs : change ownership on /var/log/ganesha] ************************************************************************************************************************************************************
fatal: [magna067]: FAILED! => {"changed": false, "failed": true, "msg": "file (/var/log/ganesha) is absent, cannot continue", "path": "/var/log/ganesha", "state": "absent"}

Additional info:
I tried two workarounds:

1. Moved the /var/log/ganesha.log file to /var/log/ganesha on the nfs client. Reran the upgrade and it finished successfully.

2. Edited the path to "/var/log/ganesha.log" in "pre_requisite_non_container.yml" in ceph-nfs tasks. Reran the upgrade and it finished successfully.

This bz has to be release noted.

Comment 6 leseb 2017-12-01 10:11:27 UTC
Just to clarify, ceph-ansible is looking for a directory not a file.
Usually /var/log/ganesha is the directory where ganesha puts its logs in.
The right work around is to create the directory: /var/log/ganesha

It is weird though, I suspect you are running an old version of ganesha.

Bara, I changed the description.