Bug 151960

Summary: gnome-volume-manager uses 100% cpu
Product: [Fedora] Fedora Reporter: Need Real Name <lsof>
Component: gnome-volume-managerAssignee: John (J5) Palmieri <johnp>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: dm, jkeck, sbruno, tatxe
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-04-16 08:13:57 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
output of "strace -o /var/tmp/log.txt gnome-volume-manager" none

Description Need Real Name 2005-03-23 16:00:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050322 Epiphany/1.5.8

Description of problem:
gnome-volume-manager is using 100% cpu.
An strace shows no activity.
A signal 15 won't kill it, a nine was needed.

How it probably happened:
Plugged in usb device, copied things off of it. turned off usb device, then removed cable.
The icon was still on the destkop. Right-clicked icon, choose Unmount. Warning showed saying it wasn't mounted, icon disappeared.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
x

Additional info:
Comment 1 Sean Bruno 2005-03-27 18:49:05 EST
Created attachment 112380 [details]
output of "strace -o /var/tmp/log.txt gnome-volume-manager"

I started gnome-volume-manager before inserting my SM card into the card
reader.  After it was started with strace, I inserted my card and noted the
following messages spewed to the terminal:

[sean@localhost ~]$ strace -o /var/tmp/log.txt /usr/bin/gnome-volume-manager
manager.c/794: New Device:
/org/freedesktop/Hal/devices/volume_part1_size_131047936
manager.c/834: Changed: /dev/sda1
manager.c/771: Added: /dev/sda1
manager.c/919: Mounted:
/org/freedesktop/Hal/devices/volume_part1_size_131047936manager.c/312: Photos
detected: /media/usbdisk/dcim


At this point, I unmounted the drive and then <ctrl-c> my strace.
Comment 2 Sean Bruno 2005-04-01 04:14:19 EST
This is still occuring as of today.  I just tested this out on my USB card
reader.  As soon as the card is inserted, gnome-volume-manager spikes to 100%
CPU useage.  I can unmount the device, but I must kill -9 gnome-volume-manager
to bring my system back to normal.

Can we escalate this one a bit?
Comment 3 John (J5) Palmieri 2005-04-01 08:27:49 EST
did you try the latest version 1.3.1?  Also provide a copy of the output of
dmesg after you plug the card in.  Some card readers have problem with the
kernel driver.
Comment 4 Sean Bruno 2005-04-01 15:36:38 EST
Grabbed this version from rawhide today.  No effect could be noted.  I am going
to reboot my machine and re-run the tests with more "stracing" and such.
Comment 5 Sean Bruno 2005-04-02 00:24:40 EST
More interesting, if not expected results from this issue.  If you do not kill
gnome-volume-manager, and umount ur media, the second insert of any media fails
to mount the device.  

So, you will have to kill the gnome-volume-manager to get this functionality
back.  At this point, am I the only one experiencing this issue?  Is this only
happening with "wierd" USB hardware?
Comment 6 Sean Bruno 2005-04-03 09:54:30 EDT
I attempted to run gnome-volume-manager with GDB to try to get some useful
information about it.  Here is what I got when I started it under GDB and
inserted my media:

manager.c/798: New Device: /org/freedesktop/Hal/devices/volume_part1_size_131047936
manager.c/838: Changed: /dev/sda1
manager.c/775: Added: /dev/sda1
Detaching after fork from child process 16764.
manager.c/923: Mounted: /org/freedesktop/Hal/devices/volume_part1_size_131047936
manager.c/313: Photos detected: /media/usbdisk/dcim
(no debugging symbols found)

---Type <return> to continue, or q <return> to quit---
Program received signal SIGINT, Interrupt.
[Switching to Thread -1208396096 (LWP 16743)]
0x068dc88f in dbus_watch_handle () from /usr/lib/libdbus-1.so.1
(gdb) where
#0  0x068dc88f in dbus_watch_handle () from /usr/lib/libdbus-1.so.1
#1  0x068b117a in dbus_connection_open () from /usr/lib/libdbus-1.so.1
#2  0x068b1cba in dbus_connection_dispatch () from /usr/lib/libdbus-1.so.1
#3  0x00c5c057 in dbus_g_pending_call_cancel () from /usr/lib/libdbus-glib-1.so.1
#4  0x00d6a46e in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#5  0x00d6d476 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#6  0x00d6d763 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#7  0x0045c39a in gtk_dialog_run () from /usr/lib/libgtk-x11-2.0.so.0
#8  0x0804b8fa in _start ()
#9  0x002bc963 in libhal_psi_get_strlist () from /usr/lib/libhal.so.1
#10 0x068b215a in dbus_connection_dispatch () from /usr/lib/libdbus-1.so.1
#11 0x00c5c21e in dbus_g_pending_call_cancel () from /usr/lib/libdbus-glib-1.so.1
#12 0x00d8fd4c in g_vasprintf () from /usr/lib/libglib-2.0.so.0
#13 0x00d6a46e in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#14 0x00d6d476 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#15 0x00d6d763 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#16 0x004cacd5 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#17 0x0804c0c7 in main ()
(gdb) f 0
#0  0x068dc88f in dbus_watch_handle () from /usr/lib/libdbus-1.so.1


I couldn't really debug the program without recompiling as all symbols have been
stripped out...
Comment 7 Sean Bruno 2005-04-06 02:51:26 EDT
Update today.  Still an issue.  If you can get a hold of an Epson Stylus CS4600
printer, maybe that will assist u in reproducing the issue.  This printer has an
integrated card reader and that is what I am using to access my mem card.
Comment 8 John (J5) Palmieri 2005-04-06 09:07:07 EDT
*** Bug 153984 has been marked as a duplicate of this bug. ***
Comment 9 John (J5) Palmieri 2005-04-06 09:09:47 EDT
This seems to be a problem when attaching storage with a /dcim directory on it
(i.e. it has photos on it and g-v-m is trying to launch gthumb).  That narrows
it down a bit.  
Comment 10 Daniel Malmgren 2005-04-06 09:31:00 EDT
Just for the record: I don't use gthumb for importing my images, but a program I
made myself for the purpose (which I call fujitrans). Any more useful
information I could provide?
Comment 11 John (J5) Palmieri 2005-04-06 10:58:29 EDT
The issue is a deadlock within D-Bus when using model dialogs (gtk_dialog_run)
and dispatching messages as the same time.  Going to try and debug the D-Bus
issue and failing that just switch to using a non-model dialog for the photo
import popup.
Comment 12 Sean Bruno 2005-04-07 02:10:20 EDT
A bit more help for you.  I can confirm that the SM card being placed in my card
reader has the "/dcim" dir.
Comment 13 Need Real Name 2005-04-07 17:43:12 EDT
Same here.
Comment 14 Sean Bruno 2005-04-08 16:44:28 EDT
New behaviour this AM after updates.  Now I get no notification from the system
that there is any activity on the USB card reader.  There was a kernel update,
so I will attempt to reboot and test to see if that has anything to do with it.

At this point, I don't even think I can manually mount the card reader as there
is nothing in /var/log/messages about the card being inserted.  Nor can I test
this bug as g-v-m doesn't get triggered to mount anything.
Comment 15 John (J5) Palmieri 2005-04-11 19:06:06 EDT
The deadlock has been fixed though I am working on getting d-bus make check to
work.  If I can't get real packages out to rawhide I will build some test
packages for you guys just to make sure it fixes the problem.
Comment 16 John (J5) Palmieri 2005-04-12 13:34:37 EDT
new dbus packages which should fix this issue are in rawhide and should show up
in tomorrows compose.  Please update to the new packages and check to see if
they fix your issues and report back here on the results.
Comment 17 Daniel Malmgren 2005-04-13 09:08:49 EDT
Yep. Did the trick for me. The effort is much appreciated!
Comment 18 Sean Bruno 2005-04-15 19:36:09 EDT
Nicely done.  I installed FC4T2, and updated to rawhide. My computer picked up
the card reader when I inserted the card and fired off the picture viewer.  No
issues noted, I believe we can call this ticket closed.
Comment 19 Need Real Name 2005-04-16 08:13:57 EDT
WFM. Thanks!