Bug 1520012

Summary: xscreensaver timebomb triggered
Product: [Fedora] Fedora EPEL Reporter: Ken Bass <kbass>
Component: xscreensaverAssignee: Lubomir Rintel <lkundrak>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: epel7CC: aparsons, cheese, herrold, lkundrak, mtasaka
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: xscreensaver-5.39-3.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-05-11 01:32:26 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ken Bass 2017-12-01 23:21:40 UTC
Description of problem:

Lock/login screen now alerts (as of Dec 1 2017) “This version of XScreenSaver is very old. Please upgrade”


Version-Release number of selected component (if applicable):

Most recent 5.35.5.el7

How reproducible:

Yes

Steps to Reproduce:
1. Lock screen
2.
3.

Actual results:

In addition to login screen, warning is displayed.

Expected results:

Should get expected login screen

Additional info:

Authors website provides 5.35.7 version - EPEL should upgrade to that.

Comment 1 Ken Bass 2017-12-01 23:28:01 UTC
NOTE: Author of software includes 18 month 'timebomb' to ensure older/buggy versions do not stagnate in repositories. That it why this triggered starting today.

EPEL version is 5.35	24-May-2016

current version 5.37    05-Jul-2017

Comment 2 R P Herrold 2018-01-31 17:42:58 UTC
The current F28 version, 
   xscreensaver-5.38-1

also builds and runs

It does have several patches which seem to no longer apply, however, when building under C7 + EPEL, updated to current

xscreensaver.src:197: W: mixed-use-of-spaces-and-tabs (spaces: line 1, tab: line 197)
xscreensaver.src: W: patch-not-applied Patch3204: xscreensaver-5.32-0004-cubestorm-enable-double-buffer-on-linux.patch
xscreensaver.src: W: patch-not-applied Patch3603: xscreensaver-5.36-0003-reset_strip-kill-gcc7-Wint-in-bool-context.patch
xscreensaver.src: W: patch-not-applied Patch3607: xscreensaver-5.36-0007-misc-kill-gcc-warn_unused_result-warnings.patch
xscreensaver.src: W: patch-not-applied Patch3604: xscreensaver-5.36-0004-init_crystal-kill-gcc7-Wint-in-bool-context.patch

Comment 3 Mamoru TASAKA 2018-02-05 12:00:19 UTC
(Just note that while the upstream may dislike, actually just rebuilding current EPEL package (with just release number bumped) will remove this warning, because Fedora's xscreensaver spec modifies the date in utils/version.h to the one when xscreensaver srpm was rebuilt, see:

https://src.fedoraproject.org/rpms/xscreensaver/blob/epel7/f/xscreensaver.spec#_440

... and I introduced this line long before xscreensaver embeds time bomb)

Comment 4 Fedora Update System 2018-04-19 02:54:54 UTC
xscreensaver-5.39-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-3cbd661ad7

Comment 5 Fedora Update System 2018-04-19 16:58:47 UTC
xscreensaver-5.39-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-3cbd661ad7

Comment 6 Ken Bass 2018-05-02 21:11:09 UTC
I tested with Centos 7.4 and it works.

I have not been able to test with Centos 7.5 because epel does not yet provide a qt5-qtwebkit for the 5.9 version of Qt included in Centos 7.5. Other epel packages like nextcloud-client require that qtwebkit so I was unable to update and test.

Comment 7 Ken Bass 2018-05-03 12:49:51 UTC
I tested on a different machine with Centos 7.5 and it works.

Also tested that it still works with two factor enabled.

Comment 8 Fedora Update System 2018-05-11 01:32:26 UTC
xscreensaver-5.39-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.