Bug 1520146

Summary: The GUI doesn't list the correct profile for swift storage
Product: Red Hat OpenStack Reporter: Udi <ukalifon>
Component: openstack-tripleo-uiAssignee: Honza Pokorny <hpokorny>
Status: CLOSED ERRATA QA Contact: Udi <ukalifon>
Severity: high Docs Contact:
Priority: medium    
Version: 12.0 (Pike)CC: hpokorny, jjoyce, jpichon, jrist, jschluet, slinaber, tvignaud
Target Milestone: betaKeywords: Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-ui-8.3.1-2.el7ost puppet-nova-12.3.1-0.20180221110444.c11423e.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:40:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Udi 2017-12-03 14:00:47 UTC
Description of problem:
The flavor for swift is called 'swift-storage', and the profile that matches this flavor is also called the same. However, in the node tagging dialog, you will not find 'swift-storage' anywhere (instead you find object-storage).

It seems like the GUI lists the roles' names instead of the flavors' profiles in the tagging dialog.


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-7.4.3-4.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. See the available tags in the node tagging dialog, and compare to the flavor names and their profiles.

Comment 1 Julie Pichon 2018-01-03 15:51:47 UTC
I think this may be related to https://bugs.launchpad.net/tripleo/+bug/1734149 and the UI / tripleo-common still relying on the deprecated names.

Comment 3 Julie Pichon 2018-03-28 08:39:05 UTC
I see some flag battling in the comments, I'm going to assume this is targeted to OSP13 based on that and the patches upstream only being submitted to Rocky and Queens. Please adjust status accordingly if that wasn't the case.

Comment 12 Udi 2018-04-09 12:47:58 UTC
Verified in: openstack-tripleo-ui-8.3.1-2.el7ost.noarch

Comment 14 errata-xmlrpc 2018-06-27 13:40:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086