Bug 152266

Summary: Media Check fails with (apparently!) valid CDs
Product: [Fedora] Fedora Reporter: Edward Kiser <edwardkiser256>
Component: kernelAssignee: Dave Jones <davej>
Status: CLOSED INSUFFICIENT_DATA QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: david.balazic, jailaney, pfrields, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-05-04 13:24:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Edward Kiser 2005-03-27 00:01:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040804 Netscape/7.2 (ax)

Description of problem:
At the beginning of the install process, when verifying CDs, every CD fails to verify. I tried this several ways and the results were the same.

* x86_64 install.
* x86_64 install with ide=nodma.
* i386 install in VMWare 5 RC3. (Using i386 binary CD disc 1 instead of x86_64 disc 1. I had VMWare mount the ISO file, bypassing the real hardware entirely.)

I downloaded with BitTorrent, so it's unlikely to be a downloading problem. The sha1sum of the disc (dd if=/dev/cdrom bs=2048 count=325415 | sha1sum) matches that of the file and also matches the sha1sum in the SHA1SUM file. This is also true for the i386 version (although count= is different of course).

CDs were burned with Roxio Creator Classic. dd revealed that the last two blocks of the iso file had been left off the cd. Adding 40K of zeroes to the iso (again with dd) and reburning seemed to fix the problem of the missing blocks, but the disc still failed verification. Also, VMWare failed without using a physical CD.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Insert disc 1 and boot off it.
2. Select "Verify Media" when given the opportunity to do so.
3. Wait for it to finish.

Actual Results:  It says "Failed"

Expected Results:  It should say "Succeeded" or "Good" or "OK" or something like that.

Additional info:

My system is a Dell Dimension 8400:

* Pentium 4 Model 660 (3.6 GHz, Hyperthreading, EM64T)
* 2 GB RAM
* NEC ND-3450A DVD+/-RW drive (IDE)

Comment 1 David Balažic 2005-04-05 08:30:23 UTC
I tried FC4-test1-i386-DVD.iso with VMWare 4.5.x. (mounted it from file).
mediacheck FAILED.

The sha1sum of the iso file is correct.

Comment 2 Patrick C. F. Ernzer 2005-04-18 10:00:28 UTC
FWIW, same problem with Virtual PC on a Mac

Comment 3 David Balažic 2005-04-18 10:24:24 UTC
Seems that the same thing happens with test2 DVDs too.

Comment 4 Jerry D. Laney 2005-04-26 21:57:12 UTC
Used FC3 with latest updates as of 4/1/2005, to download and burn FC4-test2 iso
CD's using new hp dvd630. ALL 4 CD's failed 'Media Check'! Media must be ok
since I built this current system using these CD's; and updated to the latest
files using up2date. Also using this FC4test2 system, I burned CD#1 again, and
it, too, fails 'Media Check'!

Comment 5 Edward Kiser 2005-05-24 04:12:14 UTC
FC4 test3 x86_64 DVD did not exhibit this problem. Yay!

Comment 6 Dave Jones 2005-06-27 23:29:54 UTC
Mass update of -test bugs to update version to fc4.
(Please retest on final release, and report results if you have not already done


Comment 7 Need Real Name 2005-06-28 20:53:24 UTC
On 6/19/2005, I downloaded the FC4 final release, and burned CDs. All 4 CDs
PASSED the media check test. Installation was done with no problems.

Comment 8 David Balažic 2005-06-29 06:59:39 UTC
FC4 i386 DVD is OK ( "PASS" )

Comment 9 Dave Jones 2005-09-30 06:38:28 UTC
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel ( As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.


Comment 10 Dave Jones 2005-11-10 19:41:22 UTC
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.

Comment 11 Dave Jones 2006-02-03 05:38:35 UTC
This is a mass-update to all currently open kernel bugs.

A new kernel update has been released (Version: 2.6.15-1.1830_FC4)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

Thank you.

Comment 12 John Thacker 2006-05-04 13:24:52 UTC
Closing per previous comment.