Bug 1523406

Summary: Cannot delete old events/AVC, SETroubleshoot Notifies for Old Ignored AVCs.
Product: [Fedora] Fedora Reporter: Paul DeStefano <prd-fedora>
Component: setroubleshootAssignee: Petr Lautrbach <plautrba>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 27CC: ben.r.xiao, dwalsh, mgrepl, plautrba, pmoore, vmojzis
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: setroubleshoot-3.3.17-1.fc27 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-03-06 17:27:29 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Paul DeStefano 2017-12-07 21:58:35 UTC
Description of problem:
SEtroublshoot is alerting me of old AVC alerts for which 1) I have marked as ignored and 2) I have deleted.

Version-Release number of selected component (if applicable):
setroubleshoot-3.3.12-5.fc27.x86_64

How reproducible:
Always since October 2017

Steps to Reproduce:
1. No action is required to produce this problem.

Actual results:
SEtroubleShoot pops up in the system tray every day with alerts for previously deteted and ignored AVCs

Expected results:
SEtroubleShoot shouldn't resurrect old events. 

Additional info:

Comment 1 Petr Lautrbach 2018-01-05 23:17:28 UTC
It seems to be a problem in seapplet which checks $HOME/.setroubleshoot while ignored AVC's are stored in /var/lib/setroubleshoot/

I started to work on seaplet rewrite - https://pagure.io/setroubleshoot/issue/8 - and this problem should be fixed by it.

Comment 2 Paul DeStefano 2018-01-08 05:53:15 UTC
Interesting.  I don't have the file ~/.setroublshoot.

Now, I'm getting SEAlert tray icon popping up, but setroublshooter shows nothing.  I can't interact with it at all, all buttons are gray-ed out.

I'm glad you are working on a rewrite; sounds cool.  Many thanks.

Comment 3 Benjamin Xiao 2018-02-22 01:15:56 UTC
Problem still occurs with the rewrite. I am using setroubleshoot 3.3.15. I had to delete /var/lib/setroubleshoot/setroubleshoot_database.xml a couple of times before all events were cleared up. Now it doesn't have any events, but the applet icon pops up still.

Comment 4 Fedora Update System 2018-02-26 20:33:39 UTC
setroubleshoot-3.3.17-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-c6be5e935b

Comment 5 Fedora Update System 2018-02-27 18:29:03 UTC
setroubleshoot-3.3.17-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-c6be5e935b

Comment 6 Fedora Update System 2018-03-06 17:27:29 UTC
setroubleshoot-3.3.17-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.