This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 152564

Summary: Wrong disk usage reported
Product: [Fedora] Fedora Reporter: Philippe Rigault <prigault>
Component: coreutilsAssignee: Tim Waugh <twaugh>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3   
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-03-30 08:57:57 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Philippe Rigault 2005-03-30 08:54:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux; en_US, fr) KHTML/3.4.0 (like Gecko)

Description of problem:
The disk usage reported by 'df' is wrong when I plug a 250GB USB Hard Disk 
containing one fat32 partition. 
 
# fdisk -l /dev/ubb 
 
Disk /dev/ubb: 251.0 GB, 251000193024 bytes 
255 heads, 63 sectors/track, 30515 cylinders 
Units = cylinders of 16065 * 512 = 8225280 bytes 
 
   Device Boot      Start         End      Blocks   Id  System 
/dev/ubb1   *           1       30515   245111706    c  W95 FAT32 (LBA) 
 
# grep ubb /etc/fstab 
/dev/ubb1 /media/LACIE  vfat pamconsole,exec,noauto,iocharset=utf8,managed 0 0 
 
# df -kT /media/LACIE 
Filesystem    Type   1K-blocks      Used Available Use% Mounted on 
/dev/ubb1     vfat   245051840        64 245051776   1% /media/LACIE 
 
# du -sk /media/LACIE 
108795040       /media/LACIE 
 
The disk indeed contains ~110GB and should report ~50% use. Instead, it 
reports 1% use. 
 

Version-Release number of selected component (if applicable):
coreutils-5.2.1-31

How reproducible:
Always

Steps to Reproduce:
1.  
2. 
3. 
   

Additional info:
Comment 1 Tim Waugh 2005-03-30 08:57:57 EST

*** This bug has been marked as a duplicate of 152519 ***