Bug 1527567

Summary: overcloud image build fails due to yum plugin priorities
Product: Red Hat OpenStack Reporter: Mike Burns <mburns>
Component: openstack-tripleo-puppet-elementsAssignee: RHOS Maint <rhos-maint>
Status: CLOSED ERRATA QA Contact: Shai Revivo <srevivo>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 13.0 (Queens)CC: hbrock, jjoyce, jschluet, jslagle, mburns, rhel-osp-director-maint
Target Milestone: Upstream M3Keywords: AutomationBlocker, Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-puppet-elements-8.0.0-0.20180117092204.120eca8.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:40:26 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mike Burns 2017-12-19 14:19:38 UTC
Description of problem:
A patch[1] landed upstream to always install yum-plugin-priorities in the overcloud-full image.  This does not work for OSP due to yum-plugin-priorities only existing in the Optional channel.  Since it's optional, OSP is not allowed to use that package.  

[1] https://review.openstack.org/#/c/516765/

Version-Release number of selected component (if applicable):
openstack-tripleo-puppet-elements-8.0.0-0.20171201221720.97df537.el7ost.noarch

How reproducible:
Always

build fails with "package not available" for yum-plugin-priorities

Comment 8 errata-xmlrpc 2018-06-27 13:40:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086