Bug 1529143 (CVE-2017-17787)

Summary: CVE-2017-17787 gimp: Heap-based buffer over-read in read_creator_block function in plug-ins/common/file-psp.c
Product: [Other] Security Response Reporter: Pedro Sampaio <psampaio>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: jridky, nphilipp, phracek
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: gimp 2.10.0 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-10-21 19:52:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1529149, 1857519    
Bug Blocks: 1856616    

Description Pedro Sampaio 2017-12-26 18:08:15 UTC
In GIMP 2.8.22, there is a heap-based buffer over-read in read_creator_block in plug-ins/common/file-psp.c.

Upstream bug:

https://bugzilla.gnome.org/show_bug.cgi?id=790853

Upstream patch:

https://git.gnome.org/browse/gimp/commit/?id=eb2980683e6472aff35a3117587c4f814515c74d
https://git.gnome.org/browse/gimp/commit/?id=87ba505fff85989af795f4ab6a047713f4d9381d

Comment 1 Pedro Sampaio 2017-12-26 18:30:28 UTC
Created gimp tracking bugs for this issue:

Affects: fedora-all [bug 1529149]