Bug 152963

Summary: CAN-2005-1194 Buffer overflow in the ieee_putascii() function
Product: [Fedora] Fedora Reporter: Josh Bressers <bressers>
Component: nasmAssignee: Richard Henderson <rth>
Status: CLOSED ERRATA QA Contact: Brian Brock <bbrock>
Severity: low Docs Contact:
Priority: medium    
Version: 3CC: sundaram
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: impact=low,public=20050331,source=redhat,reported=20050331
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-09-05 07:34:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Josh Bressers 2005-03-31 14:20:08 UTC
+++ This bug was initially created as a clone of Bug #152962 +++

There is a very obvious buffer overflow in ieee_putascii()

(code truncated)

static void ieee_putascii(char *format, ...)
    char buffer[256];
    vsprintf(buffer, format, ap);

At the very least it should be using a vsnprintf.

Comment 1 Josh Bressers 2005-03-31 14:20:41 UTC
This issue should also affect FC2

Comment 2 Jindrich Novy 2005-04-15 13:04:22 UTC
Applied and built in FC3. Patch added to the fedora-legacy bug for this and
CAN-2004-1287 issue.