Bug 1530117

Summary: os-collect-config is spewing a lot of useless logs
Product: Red Hat OpenStack Reporter: Rahul Chincholkar <rchincho>
Component: os-collect-configAssignee: Alex Schultz <aschultz>
Status: CLOSED ERRATA QA Contact: Gurenko Alex <agurenko>
Severity: medium Docs Contact:
Priority: medium    
Version: 10.0 (Newton)CC: apevec, aschultz, emacchi, lhh, mburns, nchandek, rhel-osp-director-maint, sbandyop, srevivo
Target Milestone: betaKeywords: Triaged
Target Release: 13.0 (Queens)   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: os-collect-config-8.1.1-0.20180119125828.621029a.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:40:49 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Rahul Chincholkar 2018-01-02 05:36:03 UTC
We currently spam the logs with this:

Jan  2 00:27:12 overcloud-compute-0 os-collect-config: /var/lib/os-collect-config/local-data not found. Skipping
Jan  2 00:27:12 overcloud-compute-0 os-collect-config: No local metadata found (['/var/lib/os-collect-config/local-data'])
Jan  2 00:27:42 overcloud-compute-0 os-collect-config: /var/lib/os-collect-config/local-data not found. Skipping
Jan  2 00:27:42 overcloud-compute-0 os-collect-config: No local metadata found (['/var/lib/os-collect-config/local-data'])
Jan  2 00:28:13 overcloud-compute-0 os-collect-config: /var/lib/os-collect-config/local-data not found. Skipping
Jan  2 00:28:13 overcloud-compute-0 os-collect-config: No local metadata found (['/var/lib/os-collect-config/local-data'])
Jan  2 00:28:43 overcloud-compute-0 os-collect-config: /var/lib/os-collect-config/local-data not found. Skipping
Jan  2 00:28:43 overcloud-compute-0 os-collect-config: No local metadata found (['/var/lib/os-collect-config/local-data'])
Jan  2 00:29:13 overcloud-compute-0 os-collect-config: /var/lib/os-collect-config/local-data not found. Skipping
Jan  2 00:29:13 overcloud-compute-0 os-collect-config: No local metadata found (['/var/lib/os-collect-config/local-data'])
Jan  2 00:29:43 overcloud-compute-0 os-collect-config: /var/lib/os-collect-config/local-data not found. Skipping
Jan  2 00:29:43 overcloud-compute-0 os-collect-config: No local metadata found (['/var/lib/os-collect-config/local-data'])
Jan  2 00:30:14 overcloud-compute-0 os-collect-config: /var/lib/os-collect-config/local-data not found. Skipping
Jan  2 00:30:14 overcloud-compute-0 os-collect-config: No local metadata found (['/var/lib/os-collect-config/local-data'])
Jan  2 00:30:44 overcloud-compute-0 os-collect-config: /var/lib/os-collect-config/local-data not found. Skipping
Jan  2 00:30:44 overcloud-compute-0 os-collect-config: No local metadata found (['/var/lib/os-collect-config/local-data'])


[root@overcloud-compute-0 ~]# head -n1 /var/log/messages
Dec 30 22:17:01 overcloud-compute-0 rsyslogd: [origin software="rsyslogd" swVersion="8.24.0" x-pid="727" x-info="http://www.rsyslog.com"] rsyslogd was HUPed


[root@overcloud-compute-0 ~]# tail -n1 /var/log/messages
Jan  2 00:32:15 overcloud-compute-0 os-collect-config: No local metadata found (['/var/lib/os-collect-config/local-data'])


[root@overcloud-compute-0 ~]# grep -E "No local metadata found|local-data not found" /var/log/messages |wc -l
11936

There is upstream bug relates to this issue. 
I have linked it with this bug.

Comment 6 Gurenko Alex 2018-05-02 12:25:55 UTC
Verified on puddle 2018-05-01.6

Logs looks much cleaner now.

rpm -q os-collect-config
os-collect-config-8.3.1-0.20180308131451.08bb3bd.el7ost.noarch

Comment 8 errata-xmlrpc 2018-06-27 13:40:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086