Bug 1533099

Summary: [3.9] Installer failed to configure AWS cloudprovider for EC2 C5 instance
Product: OpenShift Container Platform Reporter: Gan Huang <ghuang>
Component: InstallerAssignee: Russell Teague <rteague>
Status: CLOSED ERRATA QA Contact: Gan Huang <ghuang>
Severity: high Docs Contact:
Priority: high    
Version: 3.9.0CC: aos-bugs, chaoyang, ghuang, jokerman, mmccomas, wmeng
Target Milestone: ---   
Target Release: 3.9.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: Amazon EC2 C5 instances use different identifiers for bios_vendor Consequence: Code which uses this information for identifying the host as an AWS instance was not being run Fix: Added logic to use the new bios_vendor identifier Result: AWS C5 instances are properly identified by openshift-ansible code
Story Points: ---
Clone Of:
: 1538778 1538781 (view as bug list) Environment:
Last Closed: 2018-03-28 14:19:05 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1538778    

Description Gan Huang 2018-01-10 13:14:53 UTC
Description of problem:
Installer failed at task `Configure AWS cloud provider` while enabling AWS cloudprovider for EC2 C5 instance.

Go through of the issue, it appears that ansible is unable to get `ansible_virtualization_role` and `ansible_virtualization_type` for EC2 C5 instance:

$ ansible -m setup all -i /tmp/c5_host |grep "virtualization"
        "ansible_virtualization_role": "NA", 
        "ansible_virtualization_type": "NA", 

Checked on the EC2 C5 instance:
# cat /sys/devices/virtual/dmi/id/bios_vendor
Amazon EC2
# cat /sys/devices/virtual/dmi/id/sys_vendor
Amazon EC2
# cat /sys/devices/virtual/dmi/id/product_name
c5.large

Checking on a normal EC2 instance:
# cat /sys/devices/virtual/dmi/id/sys_vendor
Xen
# cat /sys/devices/virtual/dmi/id/product_name
HVM domU
# cat /sys/devices/virtual/dmi/id/bios_vendor
Xen


Version-Release number of the following components:
ansible 2.4.2.0
openshift-ansible-3.9.0-0.16.0.git.0.9f19afc.el7.noarch

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Scott Dodson 2018-01-11 15:37:03 UTC
Gan, can you provide more complete logs at -vvv level?

Comment 3 Russell Teague 2018-01-17 20:32:15 UTC
What version of boto is in use on this system?

Comment 4 Gan Huang 2018-01-18 04:56:45 UTC
# rpm -qa |grep boto
python2-boto3-1.4.4-1.fc25.noarch
python2-botocore-1.5.26-1.fc25.noarch
python3-boto-2.45.0-3.fc25.noarch
python2-boto-2.45.0-3.fc25.noarch

# rpm -qa |grep ansible
ansible-2.4.2.0-2.el7.noarch

Comment 5 Russell Teague 2018-01-18 16:25:22 UTC
Opened an Ansible issue: https://github.com/ansible/ansible/issues/35051

Comment 6 Russell Teague 2018-01-19 16:53:53 UTC
Proposed fix for openshift-anible: https://github.com/openshift/openshift-ansible/pull/6792

Comment 8 Johnny Liu 2018-01-25 05:36:31 UTC
This bug is targeted for 3.9, while this bug is attached to a 3.5/3.6/3.7 errata, pls attach it to a correct errata.

Comment 11 Gan Huang 2018-01-26 05:11:47 UTC
Fixed in openshift-ansible-playbooks-3.9.0-0.23.0.git.0.d53d7ed.el7.noarch.rpm

Comment 14 errata-xmlrpc 2018-03-28 14:19:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0489