Bug 1533730 (CVE-2018-0764)

Summary: CVE-2018-0764 .NET Core: Improper processing of XML documents can cause a denial of service
Product: [Other] Security Response Reporter: Sam Fowler <sfowler>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: omajid
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: dotnetcore 1.0.9, dotnetcore 1.1.6, dotnet 2.0.5 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-18 01:05:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1545983, 1545984, 1545985    
Bug Blocks: 1533726    

Description Sam Fowler 2018-01-12 04:40:28 UTC
.NET Core 1.0, 1.1 and 2.0 perform improper processing of XML documents. A remote unauthenticated attacker could exploit this vulnerability by issuing specially crafted requests to a .NET Core application.

References:
https://nvd.nist.gov/vuln/detail/CVE-2018-0764
https://github.com/dotnet/core/blob/master/release-notes/2.0/2.0.5.md
https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2018-0764
https://github.com/dotnet/corefx/commit/3f1155b

Comment 2 errata-xmlrpc 2018-03-01 06:12:38 UTC
This issue has been addressed in the following products:

  .NET Core on Red Hat Enterprise Linux

Via RHSA-2018:0379 https://access.redhat.com/errata/RHSA-2018:0379

Comment 3 Trevor Jay 2018-04-18 01:05:57 UTC
Closing as this flaw was addressed in an errata.