Bug 1535406

Summary: OSP10 -> OSP13 FFU upgrade: fast_forward_upgrade_playbook fails with Error: Evaluation Error: Error while evaluating a Function Call, Could not find data item nova::rabbit_password in any Hiera data file and no default supplied at /root/nova-api_upgrade
Product: Red Hat OpenStack Reporter: Marius Cornea <mcornea>
Component: openstack-tripleo-heat-templatesAssignee: Lukas Bezdicka <lbezdick>
Status: CLOSED ERRATA QA Contact: Marius Cornea <mcornea>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 13.0 (Queens)CC: ccamacho, dbecker, jschluet, lbezdick, mburns, morazi, rhel-osp-director-maint
Target Milestone: betaKeywords: Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-heat-templates-8.0.0-0.20180326192239.e59fd2c.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:42:25 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Marius Cornea 2018-01-17 10:33:57 UTC
Description of problem:

Newton -> Queens FFU upgrade: fast_forward_upgrade_playbook fails with Error: Evaluation Error: Error while evaluating a Function Call, Could not find data item nova::rabbit_password in any Hiera data file and no default supplied at /root/nova-api_upgrade_manifest.pp:6:18 on node controller-0.localdomain

Checking the overcloud controller it looks that the hierarchy section in /etc/puppet/hiera.yaml doesn't point to any files:

[root@controller-0 ~]# cat /etc/puppet/hiera.yaml
---
:backends:
  - json
  - yaml
:json:
  :datadir: /etc/puppet/hieradata/
:yaml:
  :datadir: /etc/puppet/hieradata
:hierarchy:

Comment 9 errata-xmlrpc 2018-06-27 13:42:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086