Bug 1535435

Summary: OSP10 -> OSP13 FFU upgrade: fast_forward_upgrade_playbook gets stuck while running Extra migration for nova tripleo/+bug/1656791 task
Product: Red Hat OpenStack Reporter: Marius Cornea <mcornea>
Component: openstack-tripleo-heat-templatesAssignee: Lukas Bezdicka <lbezdick>
Status: CLOSED ERRATA QA Contact: Marius Cornea <mcornea>
Severity: high Docs Contact:
Priority: high    
Version: 13.0 (Queens)CC: ccamacho, dbecker, lbezdick, mbracho, mburns, morazi, rhel-osp-director-maint, rhos-flags, sclewis
Target Milestone: betaKeywords: Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-heat-templates-8.0.0-0.20180326192239.e59fd2c.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:42:25 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Marius Cornea 2018-01-17 11:49:05 UTC
Description of problem:
OSP10 -> OSP13 FFU upgrade: fast_forward_upgrade_playbook gets stuck while running Extra migration for nova tripleo/+bug/1656791 task.

In step 1 we stop the pacemaker cluster:
https://review.openstack.org/#/c/523399/7/puppet/services/pacemaker.yaml

In step 5 we're trying to run nova-manage db online_data_migrations which fails because the cluster has been stopped in step1 and the db is not reachable:
https://review.openstack.org/#/c/522921/8/docker/services/nova-api.yaml

We need to make the db available when running db migrations.

Comment 7 errata-xmlrpc 2018-06-27 13:42:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086