Bug 1537757

Summary: Neutron uses the Nova API public endpoint which may not be always reachable from the node running the Neutron service
Product: Red Hat OpenStack Reporter: Brent Eagles <beagles>
Component: puppet-neutronAssignee: Brent Eagles <beagles>
Status: CLOSED ERRATA QA Contact: Toni Freger <tfreger>
Severity: high Docs Contact:
Priority: high    
Version: 11.0 (Ocata)CC: agurenko, amuller, aschultz, augol, beagles, cylopez, dbecker, jjoyce, jlibosva, jschluet, mburns, mcornea, morazi, rhel-osp-director-maint, slinaber, tvignaud
Target Milestone: betaKeywords: Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: puppet-neutron-12.3.1-0.20180319183812.fa94be9.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1433750 Environment:
Last Closed: 2018-06-27 13:42:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1433750    
Bug Blocks:    

Comment 7 Toni Freger 2018-05-10 06:18:44 UTC
Tested with latest puddle of OSP13 
puppet-neutron-12.4.1-0.20180412211913.el7ost.noarch


# Type of the nova endpoint to use.  This endpoint will be looked up in the
# keystone catalog and should be one of public, internal or admin. (string
# value)
# Possible values:
# public - <No description provided>
# admin - <No description provided>
# internal - <No description provided>
#endpoint_type = public
endpoint_type=internal

Comment 9 errata-xmlrpc 2018-06-27 13:42:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086