Bug 1538326

Summary: [Deployment][TLS] Using SSL URI for ovsdb_connection fails
Product: Red Hat OpenStack Reporter: Tim Rozet <trozet>
Component: openstack-neutronAssignee: Tim Rozet <trozet>
Status: CLOSED ERRATA QA Contact: Itzik Brown <itbrown>
Severity: high Docs Contact:
Priority: high    
Version: 13.0 (Queens)CC: aadam, amuller, chrisw, mkolesni, nyechiel, srevivo, trozet
Target Milestone: betaKeywords: Triaged
Target Release: 13.0 (Queens)Flags: trozet: needinfo-
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: odl_deployment, odl_tls
Fixed In Version: openstack-neutron-12.0.0-0.20180215204452.fb3f718 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
N/A
Last Closed: 2018-06-27 13:43:23 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tim Rozet 2018-01-24 20:04:55 UTC
Description of problem:
When using an ssl URI for ovsdb_connection in neutron.conf, like:
ovsdb_connection=ssl:127.0.0.1:6639

The connection will fail because there is missing SSL configuration for key, cert, and ca cert that is required when creating an SSL stream connection to OVSDB. This configuration is not part of ovsdbapp and must be setup before invoking the IDL helper function that asks ovsdbapp to open the connection.

Comment 4 Itzik Brown 2018-04-26 08:58:54 UTC
Tim.
Is it about the local connection on the controllers because it's not connected.

[root@controller-1 heat-admin]# ovs-vsctl show | head -10
fdd50b4c-a491-4308-b2a0-8a1bdfc04d2d
    Manager "ssl:172.17.1.21:6640"
        is_connected: true
    Manager "ssl:172.17.1.13:6640"
        is_connected: true
    Manager "ssl:172.17.1.19:6640"
        is_connected: true
    Manager "pssl:6639:127.0.0.1"
    Bridge br-ex
        fail_mode: standalone

Comment 5 Itzik Brown 2018-05-03 08:15:20 UTC
Checked with:
openstack-neutron-12.0.2-0.20180421011358.0ec54fd.el7ost.noarch

Comment 7 errata-xmlrpc 2018-06-27 13:43:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086