Bug 1538657

Summary: rpm-build package needs Python 2
Product: [Fedora] Fedora Reporter: Iryna Shcherbina <ishcherb>
Component: rpmAssignee: Packaging Maintenance Team <packaging-team-maint>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: ignatenko, mhroncok, mjw, packaging-team-maint, pmatilai, pmoravco, vmukhame
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: rpm-4.14.1-6.fc28 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-01-31 14:29:16 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1285816    

Description Iryna Shcherbina 2018-01-25 14:47:33 UTC
The rpm-build RPM started to require Python 2 since version 4.14.1-2.

This happened because `python-macro-helper` script was added to the package. The script has #!/usr/bin/python shebang which generates this dependency. Can it be switched to #!/usr/bin/python3?

Comment 1 Miro Hrončok 2018-01-31 13:36:39 UTC
The script actually doesn't need a shebang because it's never invoked as `.../python-macro-helper` but always as `%{__python} ... .../python-macro-helper`.

I reported that upstream already as https://github.com/rpm-software-management/rpm/issues/387

However here in Fedora this pulls python2 into the default buildroot once again, so the problem is more severe.

Comment 3 Panu Matilainen 2018-01-31 14:29:16 UTC
Fixed in rpm-4.14.1-6.fc28