Bug 1539227

Summary: mariadb won't start after dnf upgrade (F27 Server)
Product: [Fedora] Fedora Reporter: xc0ffee
Component: mariadbAssignee: Michal Schorm <mschorm>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 27CC: dciabrin, hhorak, jstanek, mbayer, mkocka, mmuzila, mschorm, praiskup
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: mariadb-10.2.12-5.fc27 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-02-04 21:50:16 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description xc0ffee 2018-01-27 01:00:31 UTC
Description of problem:
After a regular dnf upgrade (2018-01-26, 22:19 UTC) mariadb won't start anymore. MariaDB could be started before.

Version-Release number of selected component (if applicable):
mariadb 10.2.10


How reproducible:
Found similar issue here: https://ask.fedoraproject.org/en/question/116730/mariadb-wont-start-after-dnf-update/

Steps to Reproduce:
1. Fedora 27 Server with MariaDB installed
2. dnf upgrade --refresh
3. service mariadb start OR service mariadb restart

Actual results:
# service mariadb start
Redirecting to /bin/systemctl start mariadb.service
Job for mariadb.service failed because the control process exited with error code.
See "systemctl  status mariadb.service" and "journalctl  -xe" for details.


Expected results:
mariadb running

Additional info:
# systemctl  status mariadb.service
‚óŹ mariadb.service - MariaDB 10.2 database server
   Loaded: loaded (/usr/lib/systemd/system/mariadb.service; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sat 2018-01-27 01:53:26 CET; 1min 51s ago
  Process: 2478 ExecStart=/usr/libexec/mysqld --basedir=/usr $MYSQLD_OPTS $_WSREP_NEW_CLUSTER (code=exited, status=1/FAILURE)
  Process: 2440 ExecStartPre=/usr/libexec/mysql-prepare-db-dir mariadb.service (code=exited, status=0/SUCCESS)
  Process: 2415 ExecStartPre=/usr/libexec/mysql-check-socket (code=exited, status=0/SUCCESS)
 Main PID: 2478 (code=exited, status=1/FAILURE)

Jan 27 01:53:26 XXXXXXXXXXXXXXXXXXXXXXXXX mysql-check-socket[2415]: Socket file /var/lib/mysql/mysql.sock exists.
Jan 27 01:53:26 XXXXXXXXXXXXXXXXXXXXXXXXX mysql-check-socket[2415]: No process is using /var/lib/mysql/mysql.sock, which means it is a garbage, so it will be removed automatically.
Jan 27 01:53:26 XXXXXXXXXXXXXXXXXXXXXXXXX mysql-prepare-db-dir[2440]: Database MariaDB is probably initialized in /var/lib/mysql already, nothing is done.
Jan 27 01:53:26 XXXXXXXXXXXXXXXXXXXXXXXXX mysql-prepare-db-dir[2440]: If this is not the case, make sure the /var/lib/mysql is empty before running mysql-prepare-db-dir.
Jan 27 01:53:26 XXXXXXXXXXXXXXXXXXXXXXXXX mysqld[2478]: 2018-01-27  1:53:26 140514567231680 [Note] /usr/libexec/mysqld (mysqld 10.2.10-MariaDB) starting as process 2478 ...
Jan 27 01:53:26 XXXXXXXXXXXXXXXXXXXXXXXXX mysqld[2478]: 2018-01-27  1:53:26 140514567231680 [Warning] Changed limits: max_open_files: 1024  max_connections: 151  table_cache: 431
Jan 27 01:53:26 XXXXXXXXXXXXXXXXXXXXXXXXX systemd[1]: mariadb.service: Main process exited, code=exited, status=1/FAILURE
Jan 27 01:53:26 XXXXXXXXXXXXXXXXXXXXXXXXX systemd[1]: Failed to start MariaDB 10.2 database server.
Jan 27 01:53:26 XXXXXXXXXXXXXXXXXXXXXXXXX systemd[1]: mariadb.service: Unit entered failed state.
Jan 27 01:53:26 XXXXXXXXXXXXXXXXXXXXXXXXX systemd[1]: mariadb.service: Failed with result 'exit-code'.

Comment 1 Michal Schorm 2018-01-27 01:46:07 UTC
Already fixed in git.
Waiting for successful build to propose a new update.

This bug is pretty the same as for F26: #1538066

For solution look at https://bugzilla.redhat.com/show_bug.cgi?id=1373006#c4
and update /usr/lib/tmpfiles.d/mariadb.cnf configuration.

Comment 2 Fedora Update System 2018-01-27 11:11:17 UTC
mariadb-10.2.12-5.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-66833616aa

Comment 3 Fedora Update System 2018-01-28 23:05:18 UTC
mariadb-10.2.12-5.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-66833616aa

Comment 4 Fedora Update System 2018-01-29 09:27:49 UTC
mariadb-10.2.12-5.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-66833616aa

Comment 5 Fedora Update System 2018-01-29 19:08:43 UTC
mariadb-10.2.12-5.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-66833616aa

Comment 6 Fedora Update System 2018-02-04 21:50:16 UTC
mariadb-10.2.12-5.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.