Bug 1539704

Summary: gcc: Restore -fstack-clash-protection support on aarch64
Product: [Fedora] Fedora Reporter: Florian Weimer <fweimer>
Component: gccAssignee: Jakub Jelinek <jakub>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: aoliva, davejohansen, fweimer, jakub, jwakely, law, mpolacek, pbrobinson
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: gcc-8.0.1-0.4.fc28 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1539707 (view as bug list) Environment:
Last Closed: 2018-01-29 13:50:26 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 245418, 1539707    

Description Florian Weimer 2018-01-29 13:42:00 UTC
In rawhide, aarch64 uses the generic -fstack-clash-protection implementation, which shares many of the issues of the old -fstack-check option.  As a result, we need cannot build Fedora with -fstack-clash-protection hardening on aarch64.

Comment 1 Florian Weimer 2018-01-29 13:50:26 UTC
Already back since gcc-8.0.1-0.4.fc28.