Bug 1540501

Summary: Octavia client is not installed after OSP13 deployment
Product: Red Hat OpenStack Reporter: Alexander Stafeyev <astafeye>
Component: puppet-octaviaAssignee: Carlos Goncalves <cgoncalves>
Status: CLOSED ERRATA QA Contact: Alexander Stafeyev <astafeye>
Severity: urgent Docs Contact:
Priority: high    
Version: 13.0 (Queens)CC: amuller, astafeye, cgoncalves, jschluet, oblaut
Target Milestone: betaKeywords: Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: puppet-octavia-12.3.1-0.20180221121608.ebe409c.el7ost instack-undercloud-8.2.1-0.20180228034814.945b1d0.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:43:27 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Comment 2 Carlos Goncalves 2018-02-08 10:28:39 UTC
Support for EL7 needs to be added in https://github.com/openstack/puppet-octavia/blob/master/spec/classes/octavia_client_spec.rb#L30

Comment 3 Carlos Goncalves 2018-02-08 11:10:02 UTC
Comment 2 does not actually address what is being requested. puppet's spec/classes directory is meant for class tests. Fixing there is nevertheless needed as octavia client is now supported in Red Hat family.

All OpenStack puppets I have seen do not explicitly install their respective clients, except for puppet-barbican that includes the client in its api service (https://github.com/openstack/puppet-barbican/blob/master/manifests/api.pp#L334).

Comment 5 Carlos Goncalves 2018-02-08 15:45:47 UTC
The client package name is not being defined for Red Hat family: https://review.openstack.org/#/c/542268/

Comment 6 Carlos Goncalves 2018-02-08 23:23:18 UTC
puppet-tripleo also needs patching: https://review.openstack.org/#/c/542482/

Comment 8 Carlos Goncalves 2018-02-19 10:34:55 UTC
Other OpenStack services clients are being installed as dependencies of Heat. Octavia support in Heat was included upstream during Queens development cycle [1].

Recently RDO caught up with requirements for Queens and added python-octaviaclient as requirement of heat package [2]. This means the Octavia client will be installed in the undercloud and overcloud regardless.

Alex, could you please confirm on next promotion?


[1] https://review.openstack.org/#/q/topic:bug/1737567+(status:open+OR+status:merged)
[2] https://github.com/rdo-packages/heat-distgit/commit/1390505f29c1a99a9d3b2dfc3c2d0d18e54fba51#diff-21b9b50910dda0b17497b6f0f25fe932R278

Comment 13 errata-xmlrpc 2018-06-27 13:43:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086