Bug 1540608

Summary: [3.8] [OnlineStarter][free-stg][free-int]"Failed create pod sandbox"---deploy failed
Product: OpenShift Container Platform Reporter: Ben Bennett <bbennett>
Component: NetworkingAssignee: Ravi Sankar <rpenta>
Status: CLOSED CURRENTRELEASE QA Contact: Meng Bo <bmeng>
Severity: high Docs Contact:
Priority: high    
Version: 3.7.0CC: abhgupta, amurdaca, aos-bugs, bbennett, bmeng, danw, dma, eparis, haowang, hasha, hongkliu, hongli, jokerman, jupierce, juzhao, mavit, mfojtik, mifiedle, mmccomas, rpenta, schoudha, stwalter, vlaad, xiaocwan, xiuwang, xtian, yasun, yinzhou, yufchang, zzhao
Target Milestone: ---Keywords: OnlineStarter, TestBlocker
Target Release: 3.8.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: Openshift node was not waiting enough for the VNID as master assigns vnid and it could take a while to propagate to the node. Consequence: Pod creation fails Fix: Increase timeout from 1 to 5 secs for fetching VNID on node. Result: Should allow pod creation to succeed.
Story Points: ---
Clone Of: 1509799 Environment:
Last Closed: 2018-08-30 14:45:41 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1509799    
Bug Blocks: 1512717, 1540606    

Comment 2 Xiaoli Tian 2018-03-07 03:35:05 UTC
The fix is already in v3.9.1 and v3.8.0-0.4.0

Comment 3 Meng Bo 2018-03-07 10:44:14 UTC
The bug has been fixed on v3.9.3