Bug 1540978

Summary: RFE: ConfigMap injection into [builds] /
Product: OpenShift Container Platform Reporter: vfiesing <vfiesing>
Component: BuildAssignee: Adam Kaplan <adam.kaplan>
Status: CLOSED ERRATA QA Contact: Wenjing Zheng <wzheng>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 3.6.0CC: adam.kaplan, aos-bugs, jokerman, mmccomas, simon.gunzenreiner, sspeiche, vwalek, xiuwang
Target Milestone: ---   
Target Release: 3.11.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Feature: ConfigMap Build Sources Reason: use ConfigMaps as a build source, which are transparent and easier to maintain than secrets Result: ConfigMaps can be injected into any OpenShift build
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-10-11 07:19:06 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description vfiesing 2018-02-01 12:59:13 UTC
As a user of OpenShift
I want to leverage ConfigMaps
So that I can inject config/secrets into my builds.

 https://trello.com/c/9HjBzhsj/1470-configmap-injection-into-builds

Comment 1 Simon Gunzenreiner 2018-03-15 08:58:24 UTC
Maybe a different feature request, but it should also be possible to mount secrets.

Use case: protected library repositories like Nexus/Artifactory to download libraries used during the build

Comment 2 Adam Kaplan 2018-05-07 12:09:13 UTC
Source-to-image PR: https://github.com/openshift/source-to-image/pull/866
Include s2i update in origin PR: https://github.com/openshift/origin/pull/19627
API update PR: https://github.com/openshift/api/pull/43

Comment 3 Adam Kaplan 2018-06-19 20:36:31 UTC
origin PR: https://github.com/openshift/origin/pull/19655

Comment 4 openshift-github-bot 2018-06-22 18:22:30 UTC
Commits pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/1239d1f8376dedb57eef8e545b511d2cf4fa1678
build: add origin ConfigMap build source types

RFE/bug 1540978

https://github.com/openshift/origin/commit/0d0ebdf90a0e96f44c966df926ef149e2dcfa294
update-api

* update deepcopy and converters
* update swagger and protobuf spec

RFE/bug 1540978

https://github.com/openshift/origin/commit/9be6877c3d62a3f48e9bc0bbe882be5544ab0e26
build: add ConfigMap build sources

RFE/bug 1540978

Comment 5 Adam Kaplan 2018-06-25 18:38:35 UTC
oc PR in origin: https://github.com/openshift/origin/pull/20064

Comment 6 openshift-github-bot 2018-07-09 01:40:14 UTC
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/07cc8ecc52092ace3ded2d1787f5c3a030b836c7
oc: add configmaps to build via cli

RFE/bug 1540978

Comment 7 XiuJuan Wang 2018-08-13 02:25:25 UTC
This feature has included from ocp v3.11.0.10 version.

Comment 9 errata-xmlrpc 2018-10-11 07:19:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2652