Bug 154241

Summary: nfsd: nfsv4 idmapping failing: has idmapd not been started?
Product: [Fedora] Fedora Reporter: Orion Poplawski <orion>
Component: nfs-utilsAssignee: Steve Dickson <steved>
Status: CLOSED RAWHIDE QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: 3CC: dave, tjarls
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-09-06 07:43:55 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Orion Poplawski 2005-04-08 13:55:09 EDT
Description of problem:

I'm see this error in my logs.  I'm running nfs-utils from rawhide (rebuilt on
FC3) to fix another nfsv4 issue.  idmapd is running.

alexandria: Apr  5 14:58:02 alexandria kernel: nfsd: nfsv4 idmapping failing:
has idmapd not been started?
alexandria: Apr  7 03:54:43 alexandria kernel: nfsd: nfsv4 idmapping failing:
has idmapd not been started?
alexandria: Apr  8 08:56:40 alexandria kernel: nfsd: nfsv4 idmapping failing:
has idmapd not been started?
alexandria: Apr  8 10:38:59 alexandria kernel: nfsd: nfsv4 idmapping failing:
has idmapd not been started?
alexandria: Apr  8 10:39:05 alexandria kernel: nfsd: nfsv4 idmapping failing:
has idmapd not been started?

Version-Release number of selected component (if applicable):
nfs-utils-1.0.7-1

How reproducible:
Haven't tried triggering it.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Clint Goudie 2005-06-17 15:16:49 EDT
I'm also seeing this on a newly built and up2dated FC4 box
Comment 2 Clint Goudie 2005-06-17 15:18:24 EDT
from /var/log/messages
Jun 17 13:15:17 lenny kernel: nfsd: nfsv4 idmapping failing: has idmapd not been
started?

service rpcidmapd status
rpc.idmapd (pid 1516) is running...
Comment 3 Clint Goudie 2005-06-17 15:31:39 EDT
Sorry for the chain of messages. I'm also seeing this on startup:

Jun 17 13:19:51 lenny rpc.idmapd: nfsdreopen: Opening '' failed: errno 2 (No
such file or directory)

I suspect that this message is the root cause of this error...

my /etc/exports looks like 

/usr/local/somedir           *(rw,async,fsid=0,no_subtree_check)
Comment 4 Charles Lopes 2005-10-03 05:25:56 EDT
With the last rawhide build, I'm still seeing the first message here described.
Recently a post on the nfs4 mailing list has provided a fix to this problem. I
have recompiled nfs-utils-1.0.7-18.FC5 with this patch applied and it seems to
fix the problem. Here's the URL to the post with the patch:

http://linux-nfs.org/pipermail/nfsv4/2005-September/002615.html

Could you please consider adding it to the next nfs-utils build?
Thanks in advance.
Comment 5 David Abrahams 2009-03-14 02:10:55 EDT
The workaround described here seems to handle the problem: https://bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/87382/comments/14