This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 154247

Summary: Don't split system-config-kickstart messages
Product: [Fedora] Fedora Reporter: Christian Rose <menthos>
Component: system-config-kickstartAssignee: Chris Lumens <clumens>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4Keywords: i18n, StringChange
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-04-11 10:26:15 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Christian Rose 2005-04-08 14:14:31 EDT
#: ../src/packageGroupList.py:16
msgid "/comps.xml file."

#: ../src/packageGroupList.py:16
msgid "Could not start because there is no /usr/share/comps/"


Please do NOT split sentences in several translatable messages like this.
Sentences can only be properly translated when they're complete sentences.
Please see
http://developer.gnome.org/doc/tutorials/gnome-i18n/developer.html#split-sentences
for more information about this problem.

In addition, please never hard code file names and/or file paths into
translateable messages. Then each and every translation will also have to be
updated should the file name or file path have to be changed later, and that's
surely not good design. Use a *printf-style approach instead, and use %s for the
file name, so that the translateable message will be:

"Could not start because there is no %s file."

or, alternatively,

"Could not start because there is no '%s' file."