Bug 1543494

Summary: Rebase Pacemaker on upstream 2.0 line
Product: Red Hat Enterprise Linux 8 Reporter: Ken Gaillot <kgaillot>
Component: pacemakerAssignee: Ken Gaillot <kgaillot>
Status: CLOSED CURRENTRELEASE QA Contact: cluster-qe <cluster-qe>
Severity: high Docs Contact: Steven J. Levine <slevine>
Priority: high    
Version: 8.0CC: abeekhof, aherr, cluster-maint, igkioka, jruemker, kgaillot, mnovacek, phagara, tcapek, tojeline
Target Milestone: rcKeywords: Rebase
Target Release: 8.0   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: pacemaker-2.0.0-11.el8 Doc Type: Enhancement
Doc Text:
.Pacemaker 2.0.0 in RHEL 8 The `pacemaker` packages have been upgraded to the upstream version of Pacemaker 2.0.0, which provides a number of bug fixes and enhancements over the previous version: * The Pacemaker detail log is now `/var/log/pacemaker/pacemaker.log` by default (not directly in `/var/log` or combined with the `corosync` log under `/var/log/cluster`). * The Pacemaker daemon processes have been renamed to make reading the logs more intuitive. For example, `pengine` has been renamed to `pacemaker-schedulerd`. * Support for the deprecated `default-resource-stickiness` and `is-managed-default` cluster properties has been dropped. The `resource-stickiness` and `is-managed` properties should be set in resource defaults instead. Existing configurations (though not newly created ones) with the deprecated syntax will automatically be updated to use the supported syntax. * For a more complete list of changes, see link:https://access.redhat.com/articles/3681151[Pacemaker 2.0 upgrade in Red Hat Enterprise Linux 8]. It is recommended that users who are upgrading an existing cluster using Red Hat Enterprise Linux 7 or earlier, run `pcs cluster cib-upgrade` on any cluster node before and after upgrading RHEL on all cluster nodes.
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-06-14 01:58:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1552326    

Description Ken Gaillot 2018-02-08 15:08:55 UTC
Description of problem: Upstream is now on the Pacemaker 2.0.x line, and the 1.1.x line will no longer be actively developed. Due to backward compatibility issues, introducing Pacemaker 2.0.x needs to be done with RHEL 8 GA.

Comment 9 Patrik Hagara 2019-02-25 15:49:51 UTC
Regression tests are passing, marking as verified for pacemaker-2.0.1-4.el8.