Bug 1544564

Summary: Metapackage openstack-tempest-all Does Not Include Manila Tempest Tests
Product: Red Hat OpenStack Reporter: Dustin Schoenbrun <dschoenb>
Component: openstack-tempestAssignee: Chandan Kumar <chkumar>
Status: CLOSED ERRATA QA Contact: Martin Kopec <mkopec>
Severity: medium Docs Contact:
Priority: medium    
Version: 13.0 (Queens)CC: apevec, jschluet, lhh, slinaber, udesale, whayutin
Target Milestone: rcKeywords: Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tempest-18.0.0-2.el7ost.noarch.rpm Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:44:34 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Dustin Schoenbrun 2018-02-12 21:54:54 UTC
Description of problem:
When using the metapackage "openstack-tempest-all" the Manila Tempest tests are not installed. The package installs the package "python-manila-tests" which is likely the unit tests for Manila. 

Version-Release number of selected component (if applicable):
(overcloud) [stack@undercloud-0 testing_dir]$ rpm -qa | grep openstack-tempest-all
openstack-tempest-all-17.2.1-0.20180123175631.fe655fe.el7ost.noarch


How reproducible:
100%

Steps to Reproduce:
1. Run the command "yum install openstack-tempest-all"
2. Run the command "tempest list-plugins"
3. Observe that the Manila Tempest plugin is not present in the list of Tempest plugins.

Actual results:
The Manila Tempest plugin is not visible to Tempest and the correct Manila Tempest package is not installed.

Expected results:
The correct Manila Tempest package is installed and the Manila Tempest plugin shall be visible to Tempest.

Additional info:
This is likely due to either the split of Manila's unit tests out of the "regular" packages and the name of the package that actually contains the Tempest tests for Manila being renamed.

The workaround for now seems to be to install the package "python2-manila-tests-tempest" manually.

Comment 5 Martin Kopec 2018-06-11 11:28:21 UTC
The openstack-tempest-18.0.0-2.el7ost.noarch.rpm package is available in RHOS13 repository since 16-May and it contains the fix for this issue:

[stack@undercloud-0 ~]$ rpm -qa | grep "openstack-tempest"
openstack-tempest-all-18.0.0-2.el7ost.noarch
openstack-tempest-18.0.0-2.el7ost.noarch
[stack@undercloud-0 ~]$ tempest list-plugins | grep manila
|          manila_tests          |         manila_tempest_tests.plugin:ManilaTempestPlugin         |


Tested on RHOS13:
core_puddle: 2018-06-08.3

Comment 8 errata-xmlrpc 2018-06-27 13:44:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086