Bug 1547589

Summary: FFU: on 3 controller environment rabbitmq_init_bundle container only exits successfully on controller-0 during deploy_steps_playbook.yaml
Product: Red Hat OpenStack Reporter: Marius Cornea <mcornea>
Component: puppet-tripleoAssignee: Michele Baldessari <michele>
Status: CLOSED ERRATA QA Contact: Marius Cornea <mcornea>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 13.0 (Queens)CC: dbecker, jjoyce, jschluet, mbracho, mbultel, mburns, michele, morazi, rhel-osp-director-maint, sathlang, slinaber, tvignaud
Target Milestone: betaKeywords: Triaged
Target Release: 13.0 (Queens)Flags: mbracho: needinfo+
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: puppet-tripleo-8.3.1-0.20180304033908.ed3285e.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:45:38 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
controller-0_rabbitmq_bundle_init.log none

Description Marius Cornea 2018-02-21 15:05:17 UTC
Created attachment 1398794 [details]
controller-0_rabbitmq_bundle_init.log

Description of problem:

During deploy steps rabbitmq_init_bundle only runs successfully on controller-0. On the other 2 controllers rabbitmq_init_bundle times out while trying to run the /usr/sbin/rabbitmqctl -q list_users' command.

Attaching the rabbitmq_init_bundle logs.

Comment 2 Michele Baldessari 2018-03-06 07:15:11 UTC
Sketching a first pass solution here: https://review.openstack.org/#/c/549787/

Comment 11 errata-xmlrpc 2018-06-27 13:45:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086