Bug 1547949

Summary: Undercloud / Overcloud Heat stack fails on: YAQL list index out of range (includes upgrades cases)
Product: Red Hat OpenStack Reporter: Sergii Golovatiuk <sgolovat>
Component: openstack-tripleo-heat-templatesAssignee: Emilien Macchi <emacchi>
Status: CLOSED ERRATA QA Contact: Gurenko Alex <agurenko>
Severity: medium Docs Contact:
Priority: high    
Version: 13.0 (Queens)CC: aschultz, dbecker, dpeacock, jschluet, mburns, morazi, ohochman, rhel-osp-director-maint, skatlapa
Target Milestone: betaKeywords: Triaged
Target Release: 13.0 (Queens)   
Hardware: All   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-heat-templates-8.0.0-0.20180215092255.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1547955 (view as bug list) Environment:
Last Closed: 2018-06-27 13:45:38 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1547955, 1547956, 1547957    

Description Sergii Golovatiuk 2018-02-22 11:08:20 UTC
The latest YAQL (1.1.3-2.el7) introduces backward incompatible change which was not present in YAQL (1.1.0-3.el7) and below. In order to be able to upgrade to latest YAQL and not to break any new deployments or upgrades YAQL expression should be rewritten to version which is compatible in all YAQL versions. 

Upstream bug: https://bugs.launchpad.net/tripleo/+bug/1750032
Upstream fix: https://review.openstack.org/#/c/545856/1

Comment 5 Omri Hochman 2018-03-18 13:59:55 UTC
Verified with openstack-tripleo-heat-templates-8.0.0-0.20180304031146.6cd4184.el7ost.noarch

Comment 7 errata-xmlrpc 2018-06-27 13:45:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086