Bug 1549316

Summary: System freezes after OOPS during booting
Product: [Fedora] Fedora Reporter: Bill Perkins <wmp>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 27CC: airlied, ajax, bskeggs, dstolte, ewk, hdegoede, ichavero, itamar, jarodwilson, jglisse, john.j5live, jonathan, josef, kernel-maint, labbott, linville, mchehab, mjg59, steved
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: kernel-4.15.8-300.fc27 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-03-13 23:19:18 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Screen shot taken with a cell phone showing the last displayed screen with the error.
none
Screen shop taken with cell phone showing 4.15.6 Oops error. none

Description Bill Perkins 2018-02-26 23:46:34 UTC
Created attachment 1401069 [details]
Screen shot taken with a cell phone showing the last displayed screen with the error.

System freezes after displaying "Oops: 0000 [#1] SMP NOPTI" and call trace when trying to boot an AMD Optiron system running the 4.15.3 or 4.15.4 kernels.  This system booted with no problems using pre-4.15 kernels.

Comment 1 Laura Abbott 2018-02-27 19:05:09 UTC
Can you test with the kernel from https://koji.fedoraproject.org/koji/buildinfo?buildID=1050339  ? There is a possible fix there.

Comment 2 Bill Perkins 2018-02-27 21:13:27 UTC
Created attachment 1401532 [details]
Screen shop taken with cell phone showing 4.15.6 Oops error.

Comment 3 Bill Perkins 2018-02-27 21:17:36 UTC
Downloaded and rebooted suggested 4.15.6 kernel.
No Joy.  New screen shot attached.

Comment 4 Laura Abbott 2018-02-28 17:30:56 UTC
There was a fix missing from the 4.15 stable branch. I picked it up into 4.15.7, this bug will get updated when it's available.

Comment 5 Laura Abbott 2018-03-02 18:06:24 UTC
https://koji.fedoraproject.org/koji/taskinfo?taskID=25421751 the IPMI maintainer gave a few more fixes, can you test this scratch build when it finishes?

Comment 6 Bill Perkins 2018-03-02 19:08:27 UTC
(In reply to Laura Abbott from comment #5)
> https://koji.fedoraproject.org/koji/taskinfo?taskID=25421751 the IPMI
> maintainer gave a few more fixes, can you test this scratch build when it
> finishes?

Will do, IF it finishes.  https://koji.fedoraproject.org/koji/taskinfo?taskID=25421752 still shows at this time that the x86_64 kernel did fail.

Comment 7 Laura Abbott 2018-03-05 22:44:43 UTC
Sorry, there was a patch with a missing dependency in the tree, try https://koji.fedoraproject.org/koji/taskinfo?taskID=25506144

Comment 8 Laura Abbott 2018-03-05 22:45:13 UTC
*** Bug 1551285 has been marked as a duplicate of this bug. ***

Comment 9 Bill Perkins 2018-03-06 00:34:04 UTC
(In reply to Laura Abbott from comment #7)
> Sorry, there was a patch with a missing dependency in the tree, try
> https://koji.fedoraproject.org/koji/taskinfo?taskID=25506144

Installed the task build kernel-4.15.7-301.fc27 for x86_64 and it booted with no errors.  Initial functional testing on the system indicates everything is okay.

Comment 10 Laura Abbott 2018-03-06 18:41:55 UTC
Thanks for confirming! Are you okay if I give your name and e-mail to the maintainer to add a Tested-by tag?

Comment 11 Bill Perkins 2018-03-06 21:53:03 UTC
(In reply to Laura Abbott from comment #10)
> Thanks for confirming! Are you okay if I give your name and e-mail to the
> maintainer to add a Tested-by tag?

yes, that is fine with me.  Do I close this ticket or do you?

Comment 12 Laura Abbott 2018-03-07 00:09:11 UTC
I pushed the patch to the tree. It will get picked up with the next build that happens and the bug will get updated and closed through that process.

Comment 13 Fedora Update System 2018-03-10 00:59:47 UTC
kernel-4.15.8-300.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-2bce10900e

Comment 14 Fedora Update System 2018-03-11 20:59:02 UTC
kernel-4.15.8-300.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-2bce10900e

Comment 15 Fedora Update System 2018-03-13 23:19:18 UTC
kernel-4.15.8-300.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.