Bug 1549450

Summary: Better to use the same name for Clear filters, Clear Filter, Clear All Filters
Product: OpenShift Container Platform Reporter: Yadan Pei <yapei>
Component: Management ConsoleAssignee: Jakub Hadvig <jhadvig>
Status: CLOSED ERRATA QA Contact: Yadan Pei <yapei>
Severity: low Docs Contact:
Priority: medium    
Version: 3.9.0CC: aos-bugs, jhadvig, jokerman, mmccomas, spadgett, yapei
Target Milestone: ---   
Target Release: 3.10.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: When user get 'No results match' in console/catalog page, he sees two link for clearing the search keys - 'Clear Filters' and 'Clear All Filters' Consequence: User can get confused why two link with the same semantics have different wording. Fix: Rename all occurrences of 'Clear Filters' to 'Clear All Filters' Result: All links that are clearing the filters have the same working - 'Clear All Filters'
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-07-30 19:09:51 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Yadan Pei 2018-02-27 06:37:51 UTC
Description of problem:
Better use the same name for clearing filters option:Clear filters, Clear Filter, Clear All Filters

Version-Release number of selected component (if applicable):
v3.9.0-0.53.0 

How reproducible:
Always

Steps to Reproduce:
1.Go to Catalog home page at console/catalog, type keyword "test" in Search Catalog and press Enter
2.Create project and add some resources in, go to project Overview, choose filter by label, set filter criterias: app does not exist &&
app in (test)

Actual results:
1.No Catalog items are shown, two clear options are provided, one is "Clear All Filters", the other one is "Clear Filters"
2.Also no items will be shown on page, and this time the two clear options are: Clear filters and Clear Filter

Expected results:
1-2. Since "Clear All Filters", "Clear Filters" and "Clear filters" are all used to clear all filters, it's better if we could use the same name, for better user experience and automation testing as well

Additional info:

Comment 1 Yadan Pei 2018-02-27 06:43:19 UTC
The other way is also acceptable: 
An unique name for clear options besides the filters, and another unique name for clear options following the message "The filter is hiding all resources."

Comment 2 Jakub Hadvig 2018-03-02 10:23:02 UTC
Im in favor of "Clean Filters". Any suggestions Sam ?

Comment 3 Jakub Hadvig 2018-03-02 10:32:08 UTC
Sorry for typo... meant "Clear Filters"

Comment 4 Samuel Padgett 2018-03-02 20:45:36 UTC
Recommendation from Colleen and Chris is "Clear All Filters"

Comment 5 openshift-github-bot 2018-03-06 14:29:09 UTC
Commits pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/e05f85f002fa4440f80d7340f03260391c52b7da
Bug 1549450 - Better to use the same name for Clear filters, Clear Filter, Clear All Filters

https://github.com/openshift/origin-web-console/commit/0584a07536badd197d7e53ef4ba06fd8cb761dff
Merge pull request #2870 from jhadvig/BZ1549450

Automatic merge from submit-queue.

Bug 1549450 - Better to use the same name for Clear filters, Clear Filter, Clear All Filters

Reword all the `Clear Filter` into `Clear All Filters` since this wording is from patternfly.
As part of the work, it would be good also to align on the wording for case when the filters all hidding all the options, since we are using different working for the same case, eg:
1. The filter is hiding all persistent volume claims
2. The current filter is hiding all projects.
3. All pipelines are filtered.

I suggest to use the first one and modify it into "The filters are hiding all persistent volume claims", since the first one is used on most places and with this change we are moving from singular `Clear Filter` to plural  `Clear All Filters`.

@spadgett @beanh66 @cshinn PTAL

Comment 7 Samuel Padgett 2018-03-06 15:07:35 UTC
Moving back to assigned until the catalog version is bumped in origin-web-console.

Comment 8 Samuel Padgett 2018-03-06 18:12:59 UTC
We should also update the clear label in https://github.com/kubernetes-ui/label-selector

Comment 9 Jakub Hadvig 2018-03-21 12:38:54 UTC
Putting on MODIFIED since the origin-web-catalog was bumped to version 3.10.0-alpha.0

Comment 10 Samuel Padgett 2018-03-21 12:41:36 UTC
The PR that bumped catalog was: https://github.com/openshift/origin-web-console/pull/2877

Comment 12 Yadan Pei 2018-05-17 06:32:51 UTC
Checked on v3.10.0-0.46.0

1. Catalog search use "Clear All Filters" when all items are hidden by filters
2. Overview filter by name/label also show "Clear All Filters" when all resources are hidden by filters
3. Resource pages use "Clear All Filters" too when all resource items are hidden 
4. Events page use "Clear All Filters" too when all events are hidden by filters

Move to VERIFIED

Comment 14 errata-xmlrpc 2018-07-30 19:09:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816