Bug 1549849

Summary: OSP10->11->12->13 overcloud controller rpm package update fails due to openstack-heat-api-cloudwatch package conflict
Product: Red Hat OpenStack Reporter: Marius Cornea <mcornea>
Component: openstack-heatAssignee: Zane Bitter <zbitter>
Status: CLOSED ERRATA QA Contact: Ronnie Rasouli <rrasouli>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 13.0 (Queens)CC: amoralej, dbecker, jfrancoa, jschluet, mandreou, mbracho, mburns, morazi, rhel-osp-director-maint, rhos-flags, sbaker, sclewis, shardy, srevivo, tfreger
Target Milestone: betaKeywords: Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-heat-10.0.1-0.20180314232330.c2a66b1.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:46:41 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
debug info hitting this for OSP13 major upgrade during controller package update none

Description Marius Cornea 2018-02-27 21:34:34 UTC
Description of problem:
OSP10->11->12->13 overcloud controller rpm package update fails due to openstack-heat-api-cloudwatch package conflict :


--> Processing Dependency: openstack-heat-common = 1:9.0.3-1.el7ost for package: 1:openstack-heat-api-cloudwatch-9.0.3-1.el7ost.noarch
---> Package puppet-dns.noarch 0:5.1.1-0.20180215160943.99cd025.el7ost will be installed
---> Package python-docutils.noarch 0:0.12-0.2.20140510svn7747.el7ost will be installed
---> Package python2-future.noarch 0:0.16.0-4.el7ost.1 will be installed
--> Finished Dependency Resolution
Error: Package: 1:openstack-heat-api-cloudwatch-9.0.3-1.el7ost.noarch (@rhelosp-12.0-puddle)
           Requires: openstack-heat-common = 1:9.0.3-1.el7ost
           Removing: 1:openstack-heat-common-9.0.3-1.el7ost.noarch (@rhelosp-12.0-puddle)
               openstack-heat-common = 1:9.0.3-1.el7ost
           Updated By: 1:openstack-heat-common-10.0.0-0.20180211191028.3e51547.el7ost.noarch (rhelosp-13.0-puddle)
               openstack-heat-common = 1:10.0.0-0.20180211191028.3e51547.el7ost
           Available: 1:openstack-heat-common-7.0.6-1.el7ost.noarch (rhelosp-10.0-puddle)
               openstack-heat-common = 1:7.0.6-1.el7ost
           Available: 1:openstack-heat-common-8.0.6-1.el7ost.noarch (rhelosp-11.0-puddle)
               openstack-heat-common = 1:8.0.6-1.el7ost
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@controller-0 heat-admin]#

Comment 2 Mike Burns 2018-03-19 12:08:40 UTC
Was there actually a question for the needinfo?  Please include what you're asking for when setting needinfo.  Thanks

Looking at the error, it appears to be a problem with the OSP 13 heat packaging which is owned by the CloudApps DFG.  The build no longer includeds openstack-heat-api-cloudwatch but it was installed on the system.  There should be an obsoletes (preferred) or an explicit removal during upgrade.

Comment 3 Mike Burns 2018-03-19 12:12:26 UTC
It would seem that we need a patch very similar to the patch in bug 1549845 for heat.

Comment 4 Jose Luis Franco 2018-03-28 14:02:07 UTC
Could you please point me to the spec where the obsoletes for openstack-heat-api-cloudwatch should be added? I saw all these heat related distgit projects https://github.com/rdo-packages?utf8=%E2%9C%93&q=heat-distgit&type=&language=

Comment 5 Alfredo Moralejo 2018-04-02 18:52:38 UTC
I see patches to add the obsoletes for openstack-heat-api-cloudwatch in openstack-heat-common in https://review.rdoproject.org/r/#/c/12121 and https://review.rdoproject.org/r/#/c/12632 .

I'm investigating what's happening here.

Comment 6 Alfredo Moralejo 2018-04-02 18:58:44 UTC
Before having the obsoletes we had https://review.rdoproject.org/r/#/c/11777 in master but not in queens-rdo, and the patch with the obsoletes was not included in 10.0.0-0.20180211191028.3e51547 . Build in the latest puddle contains the fix:

$ rpm -q --obsoletes -p openstack-heat-common-10.0.1-0.20180314232329.c2a66b1.el7ost.noarch.rpm 
openstack-heat-api-cloudwatch < 1:10.0.0

Comment 8 Marios Andreou 2018-04-18 16:04:05 UTC
Created attachment 1423653 [details]
debug info hitting this for OSP13 major upgrade during controller package update

Hi folks, I hit this on my environment, specifically during upgrade of packages on the controller stable/pike to stable/queens (using [1] fwiw). AFAICS, I am currently on openstack-heat-api-**-10.0.0-0.xxx.el7.centos.noarch and I am being offered 10.0.1 which is the fixed in version, but as you can see from attached am still hitting it. Grateful for any info/thoughts/comments please 

thank you,

marios

[1] https://review.openstack.org/#/c/535859/25/doc/source/install/post_deployment/upgrade.rst

Comment 10 Marius Cornea 2018-04-18 16:23:46 UTC
I think I'm not seeing anymore because https://github.com/openstack/tripleo-heat-templates/blob/master/puppet/services/disabled/heat-api-cloudwatch-disabled.yaml#L70-L75 applies removes the package during fast_forward_upgrade_tasks

Comment 14 errata-xmlrpc 2018-06-27 13:46:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086