Bug 1549917

Summary: [3.7][Backport] internal image registry was down due to data race
Product: OpenShift Container Platform Reporter: Kenjiro Nakayama <knakayam>
Component: Image RegistryAssignee: Oleg Bulatov <obulatov>
Status: CLOSED ERRATA QA Contact: Dongbo Yan <dyan>
Severity: high Docs Contact:
Priority: unspecified    
Version: 3.7.0CC: aos-bugs, bparees, dyan, obulatov
Target Milestone: ---   
Target Release: 3.7.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: concurrent write to the cache. Consequence: panic occurs. Fix: protect write to the cache with mutex. Result: the cache is safe to use concurrently.
Story Points: ---
Clone Of: 1549902 Environment:
Last Closed: 2018-04-05 09:39:53 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1549902    
Bug Blocks: 1549916    

Comment 5 Dongbo Yan 2018-03-30 05:56:38 UTC
Verified
openshift v3.7.42
kubernetes v1.7.6+a08f5eeb62
etcd 3.2.8

Comment 9 errata-xmlrpc 2018-04-05 09:39:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0636