Bug 1550797

Summary: Should remove 'loading..' when browser non-existent image
Product: OpenShift Container Platform Reporter: shahan <hasha>
Component: Management ConsoleAssignee: Jakub Hadvig <jhadvig>
Status: CLOSED ERRATA QA Contact: Yadan Pei <yapei>
Severity: low Docs Contact:
Priority: medium    
Version: 3.9.0CC: aos-bugs, jhadvig, jokerman, mmccomas, smunilla, spadgett, yapei
Target Milestone: ---Flags: spadgett: needinfo? (smunilla)
yapei: needinfo? (smunilla)
Target Release: 3.10.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: User typing manually url with non-existing image. eg: /console/project/pro1/browse/images/non-existent-image Consequence: 'loading..' words will remain on the page, signalizing that the loading is still going on, even though its done and the 'The image stream details could not be loaded' alert is shown Fix: Set the 'loaded' scope variable when the image is/isn't loaded and use it in the view to hide the 'loading..' words. Result: After the attempt to load the image data, hide the 'loading..' words even if the image can't be loaded.
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-05-17 06:42:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description shahan 2018-03-02 03:24:45 UTC
Description of problem:
 Should remove 'loading..' when browser non-existent image 

Version-Release number of selected component (if applicable):
 Always

How reproducible:
 OCP v3.9.1

Steps to Reproduce:
1. Login in web console 
2. browser non-existent image via URL: console/project/pro1/browse/images/non-existent-image
3.browser non-existent pod via URL: console/project/pro1/browse/pods/non-existent-pod

Actual results:
2. Will Always have "loading.." though the error "The image stream details could not be loaded" returned
3. NO ‘loading..’ words 

Expected results:
Should remove 'loading..' when browser non-existent image like pod page.

Additional info:
image tag page has the same issue.

Comment 1 openshift-github-bot 2018-03-02 17:59:39 UTC
Commits pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/b256cc02ceaee87d836dcb9046a4d10b3bdaaab8
Bug 1550797 - Should remove 'loading..' when browser non-existent image

https://github.com/openshift/origin-web-console/commit/e3f6278722fce4d866563d9f209016f58f00ab13
Merge pull request #2867 from jhadvig/BZ1550797

Automatic merge from submit-queue.

Bug 1550797 - Should remove 'loading..' when browser non-existent image

Also fixed case when imageStream tag is missing/non-existing.

@spadgett PTAL

Comment 2 Jakub Hadvig 2018-03-04 16:54:06 UTC
Fixing PR: https://github.com/openshift/origin-web-console/pull/2867

Comment 7 Yadan Pei 2018-04-17 02:32:26 UTC
If the fix are not going to ship in 33431, we will coordinate to drop it from the advisory

Comment 8 Yadan Pei 2018-04-17 06:25:13 UTC
Please also see comment https://bugzilla.redhat.com/show_bug.cgi?id=1558863#c6

Comment 9 Samuel Padgett 2018-04-17 12:31:03 UTC
The target release was incorrectly set. This should be removed from the advisory.

smunilla@redhat.com - can you help?

Comment 11 Yadan Pei 2018-04-20 01:55:11 UTC
Samuel, could you help remove this bug from advisory 33431?

Comment 12 Yadan Pei 2018-04-20 02:29:06 UTC
Sorry fixed merged in 3.10 and could be tested, moving back to ON_QA

Comment 13 shahan 2018-04-20 02:40:09 UTC
Checked this issue in OCP v3.10.0-0.22.0,  the 'loading' will disappear if the images/images tag is not existent.

Samuel, the bug is still in advisory, please drop it. Thx

Comment 16 errata-xmlrpc 2018-05-17 06:42:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1566