Bug 1551524

Summary: wine is not installable because of unixODBC
Product: [Fedora] Fedora Reporter: oli <olze>
Component: unixODBCAssignee: Jan Staněk <jstanek>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 28CC: hhorak, jstanek, praiskup, tgl, tomm.momi
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: unixODBC-2.3.5-3.fc28 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-03-30 12:45:28 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description oli 2018-03-05 10:52:29 UTC
Description of problem:
It is impossible to install wine 

Version-Release number of selected component (if applicable):
[root@localhost yum.repos.d]# dnf info unixODBC
Last metadata expiration check: 0:04:17 ago on Mon Mar  5 11:44:28 2018.
Installed Packages
Name         : unixODBC
Version      : 2.3.5
Release      : 1.fc28
Arch         : i686
Size         : 1.4 M
Source       : unixODBC-2.3.5-1.fc28.src.rpm
Repo         : @System
From repo    : fedora
Summary      : A complete ODBC driver manager for Linux
URL          : http://www.unixODBC.org/
License      : GPLv2+ and LGPLv2+
Description  : Install unixODBC if you want to access databases through ODBC.
             : You will also need the mariadb-connector-odbc package if you want to access
             : a MySQL or MariaDB database, and/or the postgresql-odbc package for PostgreSQL.

Available Packages
Name         : unixODBC
Version      : 2.3.5
Release      : 1.fc28
Arch         : x86_64
Size         : 428 k
Source       : unixODBC-2.3.5-1.fc28.src.rpm
Repo         : fedora
Summary      : A complete ODBC driver manager for Linux
URL          : http://www.unixODBC.org/
License      : GPLv2+ and LGPLv2+
Description  : Install unixODBC if you want to access databases through ODBC.
             : You will also need the mariadb-connector-odbc package if you want to access
             : a MySQL or MariaDB database, and/or the postgresql-odbc package for PostgreSQL.

[root@localhost yum.repos.d]# dnf info wine
Last metadata expiration check: 0:04:58 ago on Mon Mar  5 11:44:28 2018.
Available Packages
Name         : wine
Version      : 3.2
Release      : 1.fc28
Arch         : i686
Size         : 57 k
Source       : wine-3.2-1.fc28.src.rpm
Repo         : fedora
Summary      : A compatibility layer for windows applications
URL          : http://www.winehq.org/
License      : LGPLv2+
Description  : Wine as a compatibility layer for UNIX to run Windows applications. This
             : package includes a program loader, which allows unmodified Windows
             : 3.x/9x/NT binaries to run on x86 and x86_64 Unixes. Wine can use native system
             : .dll files if they are available.
             : 
             : In Fedora wine is a meta-package which will install everything needed for wine
             : to work smoothly. Smaller setups can be achieved by installing some of the
             : wine-* sub packages.

Name         : wine
Version      : 3.2
Release      : 1.fc28
Arch         : x86_64
Size         : 58 k
Source       : wine-3.2-1.fc28.src.rpm
Repo         : fedora
Summary      : A compatibility layer for windows applications
URL          : http://www.winehq.org/
License      : LGPLv2+
Description  : Wine as a compatibility layer for UNIX to run Windows applications. This
             : package includes a program loader, which allows unmodified Windows
             : 3.x/9x/NT binaries to run on x86 and x86_64 Unixes. Wine can use native system
             : .dll files if they are available.
             : 
             : In Fedora wine is a meta-package which will install everything needed for wine
             : to work smoothly. Smaller setups can be achieved by installing some of the
             : wine-* sub packages.



How reproducible:
try to install wine

Steps to Reproduce:
1. dnf update && dnf install wine
2.
3.

Actual results:
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/bin/isql from install of unixODBC-2.3.5-1.fc28.x86_64 conflicts with file from package unixODBC-2.3.5-1.fc28.i686
  file /usr/bin/iusql from install of unixODBC-2.3.5-1.fc28.x86_64 conflicts with file from package unixODBC-2.3.5-1.fc28.i686
  file /usr/bin/odbcinst from install of unixODBC-2.3.5-1.fc28.x86_64 conflicts with file from package unixODBC-2.3.5-1.fc28.i686
  file /usr/bin/slencheck from install of unixODBC-2.3.5-1.fc28.x86_64 conflicts with file from package unixODBC-2.3.5-1.fc28.i686

Error Summary
-------------


Expected results:
That it installs 

Additional info:
When installing wine, it installs both unixODBC variants (i686 and x64). I guess that leads to the crash because probably both try to install to the same binary locations.

Comment 1 Fedora Update System 2018-03-07 20:12:22 UTC
unixODBC-2.3.5-3.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-79a730259e

Comment 2 Fedora Update System 2018-03-08 15:28:47 UTC
unixODBC-2.3.5-3.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-79a730259e

Comment 3 Fedora Update System 2018-03-30 12:45:28 UTC
unixODBC-2.3.5-3.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.