Bug 1553038

Summary: Failed to start heketi service on CRS setup (heketi outside openshift)
Product: [Red Hat Storage] Red Hat Gluster Storage Reporter: Apeksha <akhakhar>
Component: heketiAssignee: Michael Adam <madam>
Status: CLOSED ERRATA QA Contact: Apeksha <akhakhar>
Severity: medium Docs Contact:
Priority: unspecified    
Version: cns-3.6CC: hchiramm, kramdoss, mliyazud, pprakash, rcyriac, rhs-bugs, rtalur, storage-qa-internal, vinug
Target Milestone: ---   
Target Release: CNS 3.9   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: heketi-6.0.0-7.el7rhgs Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-05 03:10:06 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1526415    

Description Apeksha 2018-03-08 05:57:58 UTC
Description of problem:
Failed to start heketi service on CRS setup

Version-Release number of selected component (if applicable):
heketi-client-5.0.0-19.el7rhgs.x86_64
heketi-5.0.0-19.el7rhgs.x86_64


How reproducible: Once


Steps to Reproduce:

On CRS setup, whwre heketi is outside openshift it failes to start heketi service.

Logs:
Mar  8 09:40:59 dhcp47-129 heketi: Heketi 5.0.0
Mar  8 09:40:59 dhcp47-129 heketi: ERROR: Unable to open config file /etc/heketi/heketi.json: open /etc/heketi/heketi.json: permission denied
Mar  8 09:40:59 dhcp47-129 systemd: heketi.service: main process exited, code=exited, status=1/FAILURE
Mar  8 09:40:59 dhcp47-129 systemd: Unit heketi.service entered failed state.
Mar  8 09:40:59 dhcp47-129 systemd: heketi.service failed.
Mar  8 09:40:59 dhcp47-129 systemd: heketi.service holdoff time over, scheduling restart.
Mar  8 09:40:59 dhcp47-129 systemd: start request repeated too quickly for heketi.service
Mar  8 09:40:59 dhcp47-129 systemd: Failed to start Heketi Server.
Mar  8 09:40:59 dhcp47-129 systemd: Unit heketi.service entered failed state.
Mar  8 09:40:59 dhcp47-129 systemd: heketi.service failed.

[root@dhcp47-129 ~]# ls -lrt /etc/heketi/heketi.json 
-rw-------. 1 root root 2661 Mar  8 09:40 /etc/heketi/heketi.json

Comment 5 Apeksha 2018-03-14 08:26:32 UTC
Able to setup CRS (heketi outside openshift) on build - heketi-6.0.0-7.el7rhgs.x86_64

Comment 8 errata-xmlrpc 2018-04-05 03:10:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0638