Bug 1553209

Summary: mate-terminal crash when using drag-n-drop tabs
Product: [Fedora] Fedora EPEL Reporter: James Pearson <james-p>
Component: mate-terminalAssignee: Wolfgang Ulbrich <fedora>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: epel7CC: fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: mate-terminal-1.16.3-2.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-03-26 17:29:39 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description James Pearson 2018-03-08 14:01:07 UTC
Description of problem:

Dragging and dropping tabs causes mate-terminal to crash  

Version-Release number of selected component (if applicable):

mate-terminal-1.16.3-1.el7
CentOS 7.4

How reproducible:

Always

Steps to Reproduce:
1. Launch mate-terminal
2. Open a tab (File -> Open Tab)
3. Left mouse button drag a tab and drop the tab in the same terminal window

Actual results:

mate-termial crashes with:

(mate-terminal:16249): GLib-GObject-CRITICAL **: g_object_ref: assertion 'G_IS_OBJECT (object)' failed

(mate-terminal:16249): Gtk-CRITICAL **: gtk_container_get_focus_child: assertion 'GTK_IS_CONTAINER (container)' failed

(mate-terminal:16249): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

(mate-terminal:16249): Gtk-CRITICAL **: gtk_container_get_focus_child: assertion 'GTK_IS_CONTAINER (container)' failed
**
Gtk:ERROR:gtkwidget.c:5813:gtk_widget_get_frame_clock: assertion failed: (window != NULL)

Expected results:

No crash!

Additional info:

Downloading and rebuilding locally the mate-terminal-1.16.3-1.el7.src.rpm from EPEL and then installing the rebuilt RPM 'fixes' the issue

i.e. a straight rebuild of the SRPM works fine

I'm guessing the 1.16.3-1 EPEL binary may have been built against an earlier EL7 release - and 'something' has changed with EL7.4 that causes mate-terminal to crash ?

Comment 1 James Pearson 2018-03-09 11:53:21 UTC
The same mate-terminal 1.16.3 running on el7.3 doesn't have this problem

So it looks like mate-terminal needs to be rebuilt on el7.4 to run on el7.4 ?

Comment 2 Wolfgang Ulbrich 2018-03-09 19:56:08 UTC
Confirmed that a rebuild fixes the issue.
New build coming soon.

Comment 3 Fedora Update System 2018-03-09 20:13:25 UTC
mate-terminal-1.16.3-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-7c2531be5a

Comment 4 Fedora Update System 2018-03-11 20:13:01 UTC
mate-terminal-1.16.3-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-7c2531be5a

Comment 5 James Pearson 2018-03-12 14:20:59 UTC
(In reply to Fedora Update System from comment #4)
> mate-terminal-1.16.3-2.el7 has been pushed to the Fedora EPEL 7 testing
> repository. If problems still persist, please make note of it in this bug
> report.
> See https://fedoraproject.org/wiki/QA:Updates_Testing for
> instructions on how to install test updates.
> You can provide feedback for this update here:
> https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-7c2531be5a

Do you need me to provide any feedback via the above link ?
(unsurprisingly, the rebuild works fine)

Comment 6 Wolfgang Ulbrich 2018-03-12 16:42:47 UTC
Karma from  a registered user with fas account is only needed if you don't want to wait 2 weeks before the update will be pushed to stable.

Comment 7 Fedora Update System 2018-03-26 17:29:39 UTC
mate-terminal-1.16.3-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.