Bug 1553424

Summary: FFU: Add support for panko service upgrade
Product: Red Hat OpenStack Reporter: Marius Cornea <mcornea>
Component: openstack-tripleo-heat-templatesAssignee: Sofer Athlan-Guyot <sathlang>
Status: CLOSED ERRATA QA Contact: Marius Cornea <mcornea>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 13.0 (Queens)CC: apannu, dbecker, jschluet, mbracho, mbultel, mburns, morazi, rhel-osp-director-maint, rhos-flags, sathlang, sclewis
Target Milestone: betaKeywords: TestOnly, Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-heat-templates-8.0.2-0.20180414062830.5f869f2.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:35:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Marius Cornea 2018-03-08 20:31:09 UTC
Description of problem:

This BZ is to track the inclusion of https://review.openstack.org/#/c/533764/ into the downstream build.

Comment 2 mathieu bultel 2018-04-04 09:30:55 UTC
Hi Sofer,

Can you remove the workflow -1 on the cherry pick when you are ok.

Thx

Comment 3 Sofer Athlan-Guyot 2018-04-05 13:26:16 UTC
Done and added the cherry pick from ... now that master is merged.

Comment 4 Sofer Athlan-Guyot 2018-04-05 13:28:37 UTC
Just a note, the two patches are the commit and its revert as it was shown to cause ffu to fail.  We have to test if panko installation as a container in the osp13 deployment is enough.

Comment 5 mathieu bultel 2018-04-11 11:00:27 UTC
Maria, can you set the PM ack on it please.
Thank you

Comment 6 Marius Cornea 2018-04-19 15:44:47 UTC
Moving this to TestOnly as the revert is in the latest build so it only needs verification that post upgrade Panko works as expected.

Comment 9 Marius Cornea 2018-05-04 20:17:07 UTC
We can see the panko_api container created post upgrade:

[root@controller-0 ~]# docker ps | grep panko
55757845ae4b        rhos-qe-mirror-rdu2.usersys.redhat.com:5000/rhosp13/openstack-panko-api:2018-05-03.2                   "kolla_start"            46 minutes ago      Up 46 minutes (healthy)                       panko_api

Comment 12 errata-xmlrpc 2018-06-27 13:35:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086