Bug 1553893

Summary: vdsm should not report errors about guest agent
Product: [oVirt] vdsm Reporter: Dafna Ron <dron>
Component: GeneralAssignee: Dan Kenigsberg <danken>
Status: CLOSED WONTFIX QA Contact: meital avital <mavital>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.20.19CC: bugs, dron, michal.skrivanek
Target Milestone: ---Flags: michal.skrivanek: needinfo? (dron)
dron: planning_ack?
dron: devel_ack?
dron: testing_ack?
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-01-03 12:49:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Virt RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Dafna Ron 2018-03-09 19:36:32 UTC
We discovered the issue in OST. the vm starts with no guest agent and we can see errors in vdsm. 
vdsm should not report that as an error since it does not know if gues agent is installed. 


Error snippet from engine:

2018-03-04 09:50:14,823-05 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ForkJoinPool-1-worker-12) [] EVENT_ID: VM_DOWN_ERROR(119), VM vm2 is down with error. Exit message: Lost connection with qemu process.


Error snippet from host:

Mar  4 09:56:27 lago-basic-suite-4-2-host-1 libvirtd: 2018-03-04 14:56:27.831+0000: 1189: error : qemuDomainAgentAvailable:6010 : Guest agent is not responding: QEMU guest agent is not connected


You can see logs here: http://jenkins.ovirt.org/job/ovirt-4.2_change-queue-tester/1019/artifact/

Comment 1 Michal Skrivanek 2018-03-10 06:22:48 UTC
Those 2 errors do not seem related. 

Which log?

Comment 2 Ryan Barry 2019-01-03 12:49:54 UTC
This will not be addressed in a reasonable timeframe. Please re-open if it's still important.