Due to a recent update on Javascript code a full page refresh on your browser might be needed.

Bug 1554550

Summary: KDE live image notifies of available updates again (F28), via dnfdragora
Product: [Fedora] Fedora Reporter: Adam Williamson <awilliam>
Component: compsAssignee: Stephen Gallagher <sgallagh>
Status: CLOSED ERRATA QA Contact:
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 28CC: admiller, bruno, dustymabe, kevin, rdieter, robatino, vanmeeuwen+fedora, vpavlin
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-03-19 18:16:07 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1469206, 1554836    

Description Adam Williamson 2018-03-12 23:58:21 UTC
Current F28 KDE live images notify of updates, via dnfdragora:

https://openqa.stg.fedoraproject.org/tests/249509#step/desktop_notifications/27

That's after openQA boots the live image and just lets it sit for 10 minutes. Note the "177 updates available." notification from dnfdragora. This is wrong, when running live, there should be no update notifications.

Proposing as a Final blocker, per "Release-blocking desktops must notify the user of available updates, but must not do so when running as a live image" - https://fedoraproject.org/wiki/Fedora_28_Final_Release_Criteria#Update_notification

Comment 1 Kevin Kofler 2018-03-13 03:33:25 UTC
comps-f28.xml.in lists dnfdragora-updater in @kde-desktop, which is wrong, it should list only dnfdragora. Plasma uses plasma-pk-updates, not dnfdragora-updater.

The fix:
https://pagure.io/fedora-comps/c/da4785f77c22d8377001972ddf3538c55435ca71?branch=master
was only applied to f26 and f27. Then dnfdragora-gui was renamed to dnfdragora-updater:
https://pagure.io/fedora-comps/c/7012a43d4037e699069712250cbf806ef3e73505?branch=master
but this was already wrong on f28 and f29 before the rename.

Now if the people responsible for this mess can please fix it. I am not the maintainer of this stuff anymore and have not been for a couple years!

Comment 2 Adam Williamson 2018-03-13 04:52:21 UTC
Sorry Kevin, was just CCing KDE-adjacent folks, which in my mind usually maps to you and Rex :/

Comment 3 Adam Williamson 2018-03-13 16:04:59 UTC
https://pagure.io/fedora-comps/pull-request/239

Comment 4 Adam Williamson 2018-03-19 18:16:07 UTC
This looks fixed in current nightlies. The test is still failing, but it's a false failure caused by the network device notification (openQA doesn't expect that).