Bug 1554725

Summary: RFE: ibus emoji should hide missing characters by default
Product: [Fedora] Fedora Reporter: Jens Petersen <petersen>
Component: ibusAssignee: fujiwara <tfujiwar>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: 28CC: i18n-bugs, petersen, shawn.p.huang, tfujiwar
Target Milestone: ---Keywords: i18n
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1626904 1626906 (view as bug list) Environment:
Last Closed: 2019-04-09 04:14:08 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1626904, 1626906    

Description Jens Petersen 2018-03-13 08:55:29 UTC
Description of problem:
I feel it is better to hide glyphs without font coverage by default.

Version-Release number of selected component (if applicable):
ibus-1.5.18-1.fc28

How reproducible:
100%

Steps to Reproduce:
1. ibus emoji lists glyphs with no font coverage.
   (search for some less common character)

Actual results:
some tofu (unicode substitute character) glyphs listed

Expected results:
Better to hide missing glyphs by default

Comment 1 fujiwara 2018-03-14 05:44:45 UTC
Why do you think they should be hidden?
I even want to show them.
E.g. Even if emojis are missed glyphs, the code points are useful.
E.g. some control chars U+0080 to U+009F in Unicode.
They just explain no glyphs and input, output, copy paste works fine.

Comment 2 Jens Petersen 2018-03-14 07:49:56 UTC
Well you could have an option to show them. :)

Anyway close if you think it is a bad idea.

Comment 3 fujiwara 2018-03-14 08:05:42 UTC
OK, I'd leave this bug for a while to get other opinions.

Comment 4 Jens Petersen 2018-12-12 03:39:19 UTC
I don't see any missing emoji now... dunno if that is because of newer emoji font.
And search is moved to emoji input so I think this bug is already addressed.