Bug 155549

Summary: USB DVD-RW not recognized
Product: [Fedora] Fedora Reporter: David Balažic <david.balazic>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-06-06 10:34:22 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description David Balažic 2005-04-21 08:02:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
I have an external DVD-RW, connected over USB2.0.

$ cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: HL-DT-ST Model: DVDRAM GSA-4163B Rev: A104
  Type:   CD-ROM                           ANSI SCSI revision: 02

This is all. No /etc/fstab entry. No /dev/sda or similar. No icon in GNOME. Nothing.


Version-Release number of selected component (if applicable):
udev-050-10

How reproducible:
Always

Steps to Reproduce:
1. boot FC4test2


Actual Results:  No sign of DVD unit (except /proc/scsi/...)

Expected Results:  DVD unit normally usable.

Additional info:
Comment 1 Harald Hoyer 2005-04-21 08:39:14 EDT
latest udev version is 057.. please retry with updates hotplug and udev 
Comment 2 Vishenka 2005-05-14 09:27:09 EDT
I have the same problem on FC3 (yes, FC3) with udev-057-4.i386.rpm and
hal-0.5.1-1.i386.rpm installed.

# dmesg
...
usb 1-5: new high speed USB device using address 17
scsi15 : SCSI emulation for USB Mass Storage devices
  Vendor: SONY      Model: DVD RW DRU-500A   Rev: 2.1a
  Type:   CD-ROM                             ANSI SCSI revision: 02
USB Mass Storage device found at 17

# cat /proc/scsi/scsi
Attached devices:
Host: scsi15 Channel: 00 Id: 00 Lun: 00
  Vendor: SONY     Model: DVD RW DRU-500A  Rev: 2.1a
  Type:   CD-ROM                           ANSI SCSI revision: 02

# ls -l /dev/sd*
ls: /dev/sd*: No such file or directory
Comment 3 Harald Hoyer 2005-05-17 08:20:21 EDT
is the sd_mod module and sr_mod module loaded?
Comment 4 David Balažic 2005-06-01 05:19:46 EDT
Now it works.

I'm not sure what fixed it. I have :
udev-057-1
hotplug-2004_09_23-4
hal-0.5.0.cvs20050404b-2