Bug 1558015

Summary: ceph not exposing asok files via /var/run therefor collectd won't be able to load ceph plugin.
Product: Red Hat OpenStack Reporter: Leonid Natapov <lnatapov>
Component: openstack-tripleo-heat-templatesAssignee: Pradeep Kilambi <pkilambi>
Status: CLOSED ERRATA QA Contact: Leonid Natapov <lnatapov>
Severity: high Docs Contact:
Priority: medium    
Version: 13.0 (Queens)CC: gfidente, jschluet, mburns, pkilambi, rhel-osp-director-maint
Target Milestone: betaKeywords: Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-heat-templates-8.0.2-0.20180414062830.5f869f2.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:47:45 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1563280    
Bug Blocks: 1516285    

Description Leonid Natapov 2018-03-19 12:39:43 UTC
Description of problem:

ceph not exposing asok files  via /var/run therefor collectd won't be able to load ceph plugin.

collect ceph plugin is using asok file in the plugin configuration file.

" SocketPath "/var/run/ceph/ceph-osd.0.asok "

If asok file not accessible collect won't be able to load ceph plugin.

Comment 2 Giulio Fidente 2018-04-03 14:01:48 UTC
I think this will only work if the Ceph container mounts the dir on start, otherwise the socket is still only visible within the container. Will investigate with ceph-ansible team.

Comment 4 Leonid Natapov 2018-05-30 07:31:29 UTC
asok files exposed.

Comment 6 errata-xmlrpc 2018-06-27 13:47:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086