Bug 155810

Summary: OOo sementation fault on startup [kernel version specific]
Product: [Fedora] Fedora Reporter: Dawid Zamirski <dzrudy>
Component: kernelAssignee: Caolan McNamara <caolanm>
Severity: high Docs Contact:
Priority: medium    
Version: rawhideCC: doc, micwise, rouillardsy
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-04-28 11:07:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Description Flags
gdb partial output none

Description Dawid Zamirski 2005-04-23 17:49:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
All of the openoffice applications fail on startup. The problem occured after Friday's rawhide update (04/22) and is still present after upgrade to 1.9.93-1 build realeased on Saturday (04/23). I also tried to disable SELinux but it doesn't resolve the problem.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Open console
2. Run oowriter or oocalc or other component

Actual Results:  $ oowriter
/usr/lib/openoffice.org1.9.93/program/soffice: line 230:  4121 Segmentation fault      "${sd_prog}"/pagein -L"${sd_prog}" ${sd_pagein_args}
/usr/lib/openoffice.org1.9.93/program/soffice: line 241:  4122 Segmentation fault      "$sd_prog/$sd_binary" "$@"

Expected Results:  Application startup

Additional info:

Comment 1 Dawid Zamirski 2005-04-23 22:00:03 UTC
Ok, the problem seems to be with kernel because when I started the system with
kernel-2.6.11-1.1251_FC4 the program starts fine.

Comment 2 Caolan McNamara 2005-04-25 07:55:10 UTC
*** Bug 155835 has been marked as a duplicate of this bug. ***

Comment 3 Michael Wise 2005-04-26 20:08:15 UTC
I've tried kernels back to kernel-2.6.11-1.1233_FC4 and openoffice.org gives me
the Segmentation fault on all kernels.

Comment 4 Caolan McNamara 2005-04-27 13:54:21 UTC
if you have a crash can you...
>gdb /usr/lib/openoffice.org-1.9.96/program/soffice.bin
(gdb) run -writer
(gdb) bt
and post the output here

Comment 5 Sylvain Rouillard 2005-04-27 16:26:18 UTC
A little update before adding the gdb output. When I primilary reported the bug
(sorry for the dup), I was using kernel 1253. So, at that time, OOo was crashing
on 1253. I have to confess I didn't try any other kernel version.

After today's yum update, OOo became functional again on 1253. However, I still
have the bug when booting on 1268. To make sure I'm perfectly clear:

2005-04-24 09:40 EST : OOo crashes on kernel 1253
Now : OOo works on 1253 but crashes on 1268

So I support the idea that this bug is *somehow* kernel related (I use the same
config for both kernels). Now, I cannot really make a lot of tests on 1253+
kernels (see bug 155827). Yet I managed to get you a gdb output. However, I
could not perform exactly what you requested. Once I issued the run -writer
command, I see a couple of lines popping up, then my CPU usage goes up to 100%,
all used by soffice.bin, and nothing else happens. I can close the console, kill
gdb, but I cannot kill soffice.bin.

If there is anything else I can do, let me know!

Comment 6 Sylvain Rouillard 2005-04-27 16:27:33 UTC
Created attachment 113722 [details]
gdb partial output

This output covers what I get from gdb until the process hangs with a 100% CPU

Comment 7 Michael Wise 2005-04-27 17:18:30 UTC
After updating to kernel 1268 and openoffice.org-1.9.96 I am able to start and
run openoffice.org (writer, impress, and calc) with no problems.

Comment 8 Paul F. Johnson 2005-04-28 07:15:50 UTC
Works fine on kernel 1267 as well.

Comment 9 Sylvain Rouillard 2005-04-28 08:39:05 UTC
I now have the problem on 1275 too.

[sal@localhost ~]$ uname -r
[sal@localhost ~]$ oowriter
/usr/lib/openoffice.org1.9.96/program/soffice: line 230:  6080 Erreur de
segmentation  "${sd_prog}"/pagein -L"${sd_prog}" ${sd_pagein_args}
/usr/lib/openoffice.org1.9.96/program/soffice: line 241:  6081 Erreur de
segmentation  "$sd_prog/$sd_binary" "$@"

Comment 10 Caolan McNamara 2005-04-28 09:23:06 UTC
> uname -r
> /usr/lib/openoffice.org1.9.96/program/swriter
> oowriter &
[1] 3779
> rpm -q openoffice.org-core
> /usr/sbin/getenforce

ok, it works for me on that kernel. So is there any selinux settings, (the
getenforce) which might cause it, or can anyone who sees it on >=1275 get a

Comment 11 Caolan McNamara 2005-04-28 09:25:40 UTC
ack!, this is 64bit platform only ?

Comment 12 Sylvain Rouillard 2005-04-28 10:23:55 UTC
I don't know if that's 64bit only, at least me and Dawid are on a 64b arch.

I tried again to get a backtrace on 1275, following the recommandations you
provided, and I observed the same result as before: gdb gives the same partial
output, and then becomes unresponsive to any command (especially Ctrl+C as you
may imagine). It is also impossible to kill the soffice.bin process, even as
root (I get no error message when issuing the kill command, it just does not do

Comment 13 Caolan McNamara 2005-04-28 10:34:33 UTC
I wonder if there is another comparable 32bit app on 64bit which we could
experiment with to see if it's something that affects all non-native applications.

Comment 14 Sylvain Rouillard 2005-04-28 11:04:24 UTC
You are right.

This thread should probably be merged with bug 156166

Comment 15 Caolan McNamara 2005-04-28 11:07:13 UTC
had *just* figured that out :-)

*** This bug has been marked as a duplicate of 156166 ***

Comment 16 Michael Wise 2005-04-28 11:33:46 UTC
I tried updating to rawhide on a second machine.  It is not a 64bit machine.  I
get the segmentation fault on kernel-2.6.11-1.1268_FC4 and
openoffice.org-1.9.96.  When I run it using gdb it comes up fine with no errors
and no backtrace.  Does this need to be tracked seperately for the 64b.  I'm new
to this (reporting on bugs).

Comment 17 Luya Tshimbalanga 2005-04-28 17:15:33 UTC
The same problem occurs with kernel-2.6.11-1.1275 running on 32bit system.

Comment 18 Doc 2005-06-08 05:28:39 UTC
"I get the segmentation fault on kernel-2.6.11-1.1268_FC4 and
openoffice.org-1.9.96.  When I run it using gdb it comes up fine with no errors
and no backtrace."

Same issues on a 32bit system kernels 1323_FC4 and 1369_FC4.

Comment 19 Doc 2005-06-08 16:18:34 UTC
FYI, it seems to run fine in a VNC terminal window, but not on the local display :0.