Bug 1559404

Summary: Change the fluentd request timeout to be essentially infinite
Product: OpenShift Container Platform Reporter: Peter Portante <pportant>
Component: LoggingAssignee: ewolinet
Status: CLOSED ERRATA QA Contact: Anping Li <anli>
Severity: high Docs Contact:
Priority: high    
Version: 3.9.0CC: aos-bugs, jcantril, nhosoi, rmeggins, tkatarki
Target Milestone: ---   
Target Release: 3.9.z   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: logging-fluentd-docker-v3.9.22-2 Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
: 1569548 1569550 (view as bug list) Environment:
Last Closed: 2018-05-17 06:43:34 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1569548, 1569550    

Description Peter Portante 2018-03-22 13:34:43 UTC
Currently we default the indexing request timeout for fluentd to 600 seconds.  That is about 10 minutes.  In certain situations, this timeout is not long enough.  If we make this essentially infinite, we'll avoid fluentd pods re-submitting requests unnecessarily.

There should be no concerns about the infinite timeout.  If Elasticsearch is not responding, but has the connection open, then resubmitting the request will not help.

This can adversely affect large clusters with lots of indices, where certain maintenance operations can take longer than 10 minutes.

Comment 4 Anping Li 2018-04-17 04:52:19 UTC
The fix is not in logging-fluentd/images/v3.9.22-1

Comment 10 errata-xmlrpc 2018-05-17 06:43:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1566