Bug 1561115

Summary: GDM hangs when ran on VESA (BIOS/nomodeset)
Product: [Fedora] Fedora Reporter: František Zatloukal <fzatlouk>
Component: mesaAssignee: Adam Jackson <ajax>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 28CC: ajax, alexl, bskeggs, caillon+fedoraproject, fschwarz, ignatenko, jglisse, john.j5live, lruzicka, rclark, rhughes, rstrode, thatslyude
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-10 19:36:08 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
journalctl
none
lspci none

Description František Zatloukal 2018-03-27 16:06:12 UTC
Description of problem:
I've tried booting Fedora with "nomodeset". GNOME failed to load (in BIOS mode, UEFI worked just fine) on one of two tested (bare metal) desktops.

Version-Release number of selected component (if applicable):
gdm-3.28.0-6.fc28.x86_64
mesa-dri-drivers-18.0.0-0.3.rc4.fc28.x86_64

How reproducible:
Always(?)

Steps to Reproduce:
1. Boot Fedora with nomodeset


Actual results:
After logging in, screen stays with grayish (gdm) background with no content.

Expected results:
GNOME should work with VESA driver.

Comment 1 František Zatloukal 2018-03-27 16:08:03 UTC
Created attachment 1413792 [details]
journalctl

Comment 2 František Zatloukal 2018-03-27 16:08:27 UTC
Created attachment 1413793 [details]
lspci

Comment 3 Lukas Ruzicka 2018-04-04 12:15:28 UTC
I have tested today with the latest build (https://kojipkgs.fedoraproject.org/compose/branched/Fedora-28-20180403.n.0/compose/Everything/x86_64/iso/Fedora-Everything-netinst-x86_64-28-20180403.n.0.iso) and the installation was working on our bare metal. There were some blinking and glitching of the screen, but finally it was able to set up and display everything correctly.

Comment 4 Adam Jackson 2018-04-10 19:36:08 UTC
bře 27 16:20:54 localhost.localdomain gnome-shell[1319]: Failed to create backend: Could not find a primary drm kms device
bře 27 16:20:55 localhost.localdomain gnome-session[1275]: gnome-session-binary[1275]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1

This should be fixed in mesa 18.0.0-4.fc28.